BMW Forums : BimmerForums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi guys,

I'm new to the forum but have a problem hope you lot can help me with. Every morning apart from a handful of times when I pull out of the drive then 30 sec later the ECU lights come on. Whilst the ECU light is on it drives fine. I then switch the car off then back on and its gone away and doesn't come in until next morning.

I got the codes read and a few errors came up, they were cleared but the above came back on straight away. I presume its a low pressure sensor that needs changing or could it be something else. Like I said there a handful of times where it hasn't come on do you think it worth leaving it for a while and maybe it will go away eventually, if I did do that will it make the problem worse. It drives fine and no hesitation in the power etc.

Thanks in advance :thumbsup
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Even though it gives the 29f3 low pressure sensor could it be the other things you mentioned.

I'll try the sensor first, could you direct me to someone that sell them.
 

·
Super Moderator
Joined
·
12,935 Posts
its gonna be the cheapest one to rule in,or out ide say...yav realistically got no choice, ya have got to start eliminating supects..if ya took it to dealers all they would do is change stuff till its was cleared and chargeya for it...
 

·
Registered
Joined
·
12 Posts
Discussion Starter #14
Do you think it worth waiting for a month or so and see if the problem goes away as 1 guy on another forum said it eventually went away, as a handful of times on a morning start when it usually comes on it hasn't.

Also if I did do this will I make things worse if it doesn't go off, it drives fine when the ecu light is on or off.
 
1 - 15 of 15 Posts
Top