BMW Forums : BimmerForums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, looking for a little advice regarding the title above.

I have a 2014 F15 X5 30d (I'm told with the 8-speed box) that I have noticed in the past couple of weeks has started to feel 'rough' when downshifting into low gears. I would say it's noticeable below around 25mph when slowing down or coming to a stop. No noises or thumps/clunks etc just a slight 'judder' or 'jump'. It's not really noticeable when accelerating but I feel I may have noticed it once or twice.

Just wondering if anyone has experienced similar issues and what the likely cause is? I've spoken to a transmission specialist who says it could be low/poor quality fluid but could equally be something else. A full fluid change with this place is approx. £1k :)jaw-dropping) - does that sound about right?

I'm just a little concerned about booking the car in for a £1k job only to find it's actually something else.

Any help/advice much appreciated. I'm in North Kent so any recommendations of garages to speak to also welcomed.

Thanks again

R.
 

·
Registered
Joined
·
1 Posts
Hi, looking for a little advice regarding the title above.

I have a 2014 F15 X5 30d (I'm told with the 8-speed box) that I have noticed in the past couple of weeks has started to feel 'rough' when downshifting into low gears. I would say it's noticeable below around 25mph when slowing down or coming to a stop. No noises or thumps/clunks etc just a slight 'judder' or 'jump'. It's not really noticeable when accelerating but I feel I may have noticed it once or twice.

Just wondering if anyone has experienced similar issues and what the likely cause is? I've spoken to a transmission specialist who says it could be low/poor quality fluid but could equally be something else. A full fluid change with this place is approx. £1k :)jaw-dropping) - does that sound about right?

I'm just a little concerned about booking the car in for a £1k job only to find it's actually something else.

Any help/advice much appreciated. I'm in North Kent so any recommendations of garages to speak to also welcomed.

Thanks again

R.
Hi,did you get this sorted out?Have you posted in another forum for answers?
Have the same thing with mine -14 F15.....
 
1 - 2 of 2 Posts
Top