BMW Forums : BimmerForums banner
1 - 20 of 29 Posts

·
Registered
Joined
·
217 Posts
I may be wrong but seems to indicate a line bus wire fault from the roof function center (module in Interior light at the front). I do not have wiring diagrams handy but you could check the wire/connection from the module to your rain/light sensor on the windscreen and rearview auto dimming mirror.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #3 ·
I may be wrong but seems to indicate a line bus wire fault from the roof function center (module in Interior light at the front). I do not have wiring diagrams handy but you could check the wire/connection from the module to your rain/light sensor on the windscreen and rearview auto dimming mirror.
Oh, could this be why my auto wiper mode doesn't change the speed of the wipers (from looking in the manual the A button on the wiper stork should put it in auto mode)?
 

·
Registered
Joined
·
217 Posts
Yes that would prevent your auto wipers from working. Maybe the sensor on the windscreen is duff but check the wires first.
 

·
Registered
Joined
·
217 Posts
The plastic cover on the windscreen can be easily removed to inspect that side of the wiring. Not sure about the interior light, I tried to remove mine a good few years back but I was unsuccessful, I would have had to take my sun visors off and lower my roof lining at the front to put my hand in to pop it out so decided not to bother. I do not know how to test the sensor apart from trying to calibrate it which would also have to be done in addition to being registered to the car if replaced.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #7 ·
Ah ok,
The plastic cover on the windscreen can be easily removed to inspect that side of the wiring. Not sure about the interior light, I tried to remove mine a good few years back but I was unsuccessful, I would have had to take my sun visors off and lower my roof lining at the front to put my hand in to pop it out so decided not to bother. I do not know how to test the sensor apart from trying to calibrate it which would also have to be done in addition to being registered to the car if replaced.
Ah ok, are the sensors easy to swap?

Do you know which 1 it is, these all come up on realoem.com with my vin

Font Terrestrial plant Number Screenshot Electric blue
 

·
Registered
Joined
·
217 Posts
I think that list is only showing one rain sensor 61359224853, the bottom ones look like windscreens. Best to check what is actually fitted on your car.

 

·
Registered
Joined
·
46 Posts
Discussion Starter · #9 ·
I think that list is only showing one rain sensor 61359224853, the bottom ones look like windscreens. Best to check what is actually fitted on your car.

OK that doesn't look too bad. But it's not a plug and play item?
 

·
Registered
Joined
·
217 Posts
What I can gather is with a replacement used rain/light sensor is the rain sensor would need to be coded to your vehicle and then initialized. Also the light sensor would need to be coded.
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #13 ·
What I can gather is with a replacement used rain/light sensor is the rain sensor would need to be coded to your vehicle and then initialized. Also the light sensor would need to be coded.
I don't have auto lights, unless it's the light sensor for auto dimming mirror, tbh not checked if that works lol
 

·
Registered
Joined
·
217 Posts
I would have thought if you had auto wipers with rain/light sensor that you would also have auto lights on the car.
 

·
Registered
Joined
·
217 Posts
Looks like you do not have a rain/light sensor. I don't think anything else is connected to the line bus in the roof function center.
 
1 - 20 of 29 Posts
Top