BMW Forums : BimmerForums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi, im experiencing some very high pressure on my coolant system, and coolant overflows at expantion tank cap . Temperatures dosent go above 90 . If i drive it below 2000 RPM seems ok, i can drive it long distances . and no pressure, the hoses are not hard, but once i push the card for hard accelerations ( 2000-4000 rpm ) the preassure will increase in a couple of minutes and start leaking at expantion tank cap

No coolant in oil, no oil in coolant, no white smoke , the car drivers fine, no power loss, no strange noises, no vibrations, iddle is good

Im giving a guess at : head gasket, egr cooler , cracked cylinder head, craked engine block ? whats the most likely/unlikely ?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Snowblind - no dexcool no, and at the moment running just on pure water (distilled water ) , no coolant, just for tests Clavurion
Clavurion - ive ordered a exhaust gas tester ( the one that changes color ) , will arrive in a few days
 

·
Super Moderator
Joined
·
3,106 Posts
Mileage? Mapped (if yes, what figures)? Have you checked how coolant temp behaves (cluster hidden menu or with diagnostics)?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
246.000 km , if mapped well i bought it recently and i have no ideea if yes or no, it could be .. how do i acces the cluster hidden menu ?

anyway, the pressure that build up is high, even after the engine/coolant has cooled down , when i open expantion tank cap , it will overflow alot of liquid and release alot of pressure

if its compresion that is inside, once i open the cap and all pressure and liquid overflows , how come i dont smell anything ? shouldnt is smell like exhaust ?
 

·
Registered
Joined
·
47 Posts
Sounds very much like head or gasket issue to me allowing combustion gasses to enter the cooling system.
A block tester is unlikely to show anything unless you can use it while at higher revs under load so engine is working hard on a diesel.

I had an old vag pd that was doing the same as yours, block test passed fine,when head was off gasket clearly had track marks where gasses were passing. New gasket and head checked no further issues.
 

·
Registered
Joined
·
2,785 Posts
if its not over heating then i doubt the head gasket is at fault..and if it has an airlock i think it would still over heat,,i would get coolant changed and bled properly then go from there..
 

·
Registered
Joined
·
25 Posts
246.000 km , if mapped well i bought it recently and i have no ideea if yes or no, it could be .. how do i acces the cluster hidden menu ?
The wonderful world of YouTube will provide.

Basically you hold down the trip needle on the instrument cluster, add up some numbers, use the figure to unlock the menu then scroll through till you find the temp.

Seriously 10’s of vids explaining this exact thing.
 
1 - 9 of 9 Posts
Top