BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
I replaced the starter the other day and now the car starts fine, idle is ok for a few seconds and then it starts going up and down as if it's about to die. When it starts this mood swings, a yellow warning indicator in the middle flashes. The EML light is constantly on, but only the text one: the engine symbol next to it is off.

The OBD scanner lists throttle position sensor faults, but that's connected and I did not mess with it.

Thoughts?
 

·
Registered
Joined
·
206 Posts
Cant say I have ever experienced this but from what I know it does not sound related to the starter, could just be a coincidence that the throttle sensor has gone as soon as you changed the starter.

Maybe change that and see if its okay from there? Is it pricey

Sent from my SM-G975F using Tapatalk
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
I can't see how it's failed, as I disconnected the battery before unplugging any wire, and the throttle body was removed with the inlet manifold.

A new one is about £50, but I've found a process to reset it so I'll try that first when I get back home.
 

·
Registered
Joined
·
206 Posts
Thats where I would start before throwing money at it, what happens if you clear fault codes and try and run it?

£50 aint bad but if you just bought a new starter as well its certianly unwarranted if you can reset it

Sent from my SM-G975F using Tapatalk
 
1 - 5 of 5 Posts
Top