BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
Hi guys, I've got a couple of annoying issues that have very recently cropped up with my e90 320d, and so far I've not been able to find the solution for either so am wondering if anyone can help suggest how to fix these myself (rather than take it to someone).

First is that me screen wash stopped working. At first I thought the nozzles had blocked as I was sure there was plenty of fluid. Then I noticed that the tank did need filling/topping up so I did that but still nothing.

It was then that I noticed no motor sound when I try to use them, so it seems to be properly dead. I've checked fuses that I think are the correct ones and they're all ok, so not sure what to look at next?


Second is that the other day the rear passenger window stopped working. No horrible noises from it, it wasn't even being used but I was sitting in the car and the warning noises binged and displayed the window error symbol.

I cannot move the window up or down, and the normal trick of holding the switch down then up for 10 seconds or whatever (have to do this sometimes on the driver door when it starts only moving in small increments) is not working. The warning bing sounds roughly every 10 seconds, and after a few days of this it's getting pretty old already!

I don't imagine this is a mechanical fault since the window was up and not being used when this happened, so is there another kind of reset I can do to fix this?

Many thanks for any useful info. With all due respect to anyone trying to be helpful I'm not looking for the response "take it do your dealer"
 

·
Registered
Joined
·
51 Posts
Discussion Starter #2
Well, one problem down, one to go.

New pump fitted today on the offchance it might help and washers are working fine now! You don't realise how annoying it is not to have them working for a few weeks!!

So I guess that the system either knows if the pump isn't working, OR that no water has come out, and disables the wipers in that case. Bit stupid that it can figure that out but not actually tell you anything is wrong despite all the other warnings you get!
Also, people say you need to remove the wheel to do this but I managed to swap the pump without (as I couldn't find the locknut adapter). Was awkward doing it this way but not that bad.


BUT, I've got nowhere with this window problem. :(

The faults I can see in Inpa show the following:

ADR: Gen. Name: Error code: Kind of error: What is it?:
00 JBBF A72C 68 Is this a window sensor or door lock fault?
A72D 68 Is this a window sensor or door lock fault?
A6D1 61 Washer pump - auxiliary waterpump (for heater circulation with not washers )


29 DSC 5DE3 60 Rear Brake pads wear (I think). Will inspect and get new pads.



0xA72C hallsensor1_fh_bf_hinten
0xA72D hallsensor2_fh_bf_hinten
0xA6D1 Zusatzwasserpumpe
Unplausibles signal oder wert

I have removed the door card and have unplugged the window motor (it is a 5 wire connector on it), and have unplugged the door lock, but neither of these have made it stop giving me the same stupid damn alert noise every ten seconds or so. It's starting to get really annoying after a few weeks of hearing it now!!!

I really would be mega grateful if anyone has ideas about this window problem and if there is something specific I can do with the software to reset or something, other than just generally clearing the error memory?
 

·
Registered
Joined
·
51 Posts
Discussion Starter #3
Pretty please with sugar on top can anyone offer any info on how to stop the alert sounding for this every 10 seconds or so?

Really appreciate if anyone can help, thanks.
 
1 - 3 of 3 Posts
Top