BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,052 Posts
Discussion Starter #1
Over the last few months my car seems to have developped a tendancy to "stall".

When the engine is cold there is no problem

Once the engine warms up I have observed the following :-

Under idle conditions everything is OK - the engine idles very smoothly at 700 rpm

However when driving, the engine speed dips very low when changing gears - so to explain - I operate the clutch (manual box) and the engine speed drops of course. If I maintain the clutch depressed the engine speed will sometimes drop as low as 500 rpm before picking back up to 700.

Of course if I quicklly engage the next gear this is not a problem.

There are no other problems with the car. No lights, no codes and it runs really well.

Could this be an issue with a crankshaft position or camshaft position sensor for example ??

Any ideas you guys have will be very welcome

Thanks

Digby
 

·
Registered
Joined
·
6 Posts
May be a problem with the clutch switch.
If you depress the clutch when standing do the revs go up.
I belive there maybe a software update for this fault.
 

·
Registered
Joined
·
1,052 Posts
Discussion Starter #4
Hi guys thanks for the ideas

The EGR valve was cleaned out just a few months ago so I dont think it is to blame

Need to do a check on the clutch although I dont remember noticing anything - I will confirm later today

Thanks
 

·
Registered
Joined
·
1,052 Posts
Discussion Starter #5
So - it took a bit longer than planned but I checked out the effect of pressing the clutch in neutral

Basically no effect

With either a hot or cold engine pressing in the clutch changes nothing at all.

It seems the clutch switch works because the cruise control disengages with the slightest pressure on the clutch pedal.

Any other ideas ??

thanks

digby
 
1 - 5 of 5 Posts
Top