BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi, I'm new to this forum and have recently purchased a 2004 e60 530d auto with 88k on the clock. When attempting to accelerate, there is no power even with the foot right to the floor and the revs will not go above 3000. Readings indicated a problem with the dpf which was cleaned out by the indy dealer and the problem came back after about a week. The problem them showed as a fuel filter issue which has been replaced only for the problem to come back after a few days. I'm going back to the dealer tomorrow but would welcome any suggestions as I'm losing confidence in the car. Many thanks for any suggestions.
 

·
Bimmerforums Central
Joined
·
8,030 Posts
Hi, I'm new to this forum and have recently purchased a 2004 e60 530d auto with 88k on the clock. When attempting to accelerate, there is no power even with the foot right to the floor and the revs will not go above 3000. Readings indicated a problem with the dpf which was cleaned out by the indy dealer and the problem came back after about a week. The problem them showed as a fuel filter issue which has been replaced only for the problem to come back after a few days. I'm going back to the dealer tomorrow but would welcome any suggestions as I'm losing confidence in the car. Many thanks for any suggestions.
Ive moved this to the right tech section :)
Have the fault codes been read from the car? if not they need to be reset, and the car driven a little, and then they need to be re checked
 

·
Registered
Joined
·
363 Posts
exhaust manifold blown would cause a similar effect - the symptoms sound the same as a problem i had and it turned out to be that...
 
1 - 5 of 5 Posts
Top