BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello guys,

I've recently bought from a lady a 2004 330cd sport 154 000 miles on the clock .

She said the car was well taken care of it's just it was driven for a month or so ( about 8000 miles) just city , start stop , traffic

The car it's smoking white, not continously, It's seems it's worst on start up and under hard acceleration. The smoke smells like diesel, it's white.

One garage diagnosed the car with one bad injector because when disconnected it wouldn't change anything on how the engine runs. I changed the injector and after would act the same, no change in how the engine runs when the injector is disconnected. The guy showed me that the injector it s working by disconnecting another one, which changed the way the engine runs, and then he disconnected the one he just changed and the engine stopped. He plugged the car again and it showed 6 glow plugs and engine smooth controller. I changed all 6 glow plugs and the car is still the same. Now it's got just engine smooth controller error. He's also done the water test on injectors, no leaks.

The guy says that it might be cyl 3 bad compression, sticky valves or head gasket and wants to take the top end off......... He says he can hear bad compression in cyl 3.

For short:

Losing coolant
White smoke diesel smell that puffs when you hard accelerate or when car is idle.
Car judders, sometimes worse
Sometimes on idle or when cruising the revs oscillate just a little bit.
Loss of power
Bad MPG
Engine smooth controller error
Running rough

What I've done so far:

Changed 6 glow plugs
Changed injector no 3


I know there is a problem with the EGR because when you disconnect the small hose is not sucking at all but the guy said this is not what is causing the problem.

I sprayed a can of EGR intake turbo cleaner inside the engine and kept the rpv over 2000, the spray revving the engine to 3-4 k and after it didn't judder that hard for some hours. There was some black smoke while spraying and after straying no smoke at all. Thinking is better compression when revving that s why it didnt smoke?

Does the engine have really big carbon build up for being driven in the city for so long or is it something else?

Will update tomorrow with a video. I can't start it now since the coolant level is very low
 

·
Super Moderator
Joined
·
3,045 Posts
Code for smooth running control -> Check injector correctional values with diagnostics. If some injector has high positive correctional value try bending and pushing the connector on that injector to see it the value changes.

What was the situation with intake manifold swirl flaps (seen when manifold was off)?

White smoke and loosing coolant -> Most likely cause internally leaking EGR cooler (coolant to exhaust).
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Code for smooth running control -> Check injector correctional values with diagnostics. If some injector has high positive correctional value try bending and pushing the connector on that injector to see it the value changes.

What was the situation with intake manifold swirl flaps (seen when manifold was off)?

White smoke and loosing coolant -> Most likely cause internally leaking EGR cooler (coolant to exhaust).
Thanks for your reply Clavurion.

I'm now thinking about swirl flaps too as it seems car is losing oil as well...

Will ask the garage to check maf, injector values, pcv, ccv, glow plugs controller, compression test and sniff test, check for leaks and check egr cooler and egr which I M SURE it s blocked.

Is there anything else i might be missing and it s worth cheching before taking top end off ?

thanks
 
1 - 3 of 3 Posts
Top