BMW Forums : BimmerForums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
Hello everyone,

I have a 2004 320d touring and I'm getting a ticking kind of noise from the engine when accelerating in first and second gears, perhaps even third but if there is ticking it's nearly inaudible. This only happens at around 2000 rpm to around 3000 rpm. Additionally my car seems to lack power at low rev range
Also after accelerating hard you can smell fuel burning (leaking onto exhaust manifold) but not all the time, generally when engine has not warmed up completely.
I've tried disconnecting MAF and car had a lot more grunt and no lack of power down low in rev range and almost no ticking noise but leaking fluid remains a constant if not worse with disconnected MAF (engine was cold/semi cold during DC'd MAF drives).
Another thing is that mpg is higher than that of other people i know who also have e46 320d with the same engine/chassis.

I have also driven around with laptop connected running INPA and so far i've seen anomalies with charged air level being lower than desired and fuel rail pressure being a lot higher than desired when planting the pedal, everything seems to be about even when cruising.

When MAF is connected current and desired air mass values are consistent across the board so i've ruled out MAF from my possible culprit list

I have noticed that there's a lot of fluid spilled around the area of air pipe connecting to turbo (should this pipe have a clamp or something on turbo side ?) and ould this be related ?
Turbo itself looks, sounds and feels healthy as it does kick in at around 2k rpm as it should.

This issue appeared about a week ago and since then I have changed air filters, oil & filter, breather & gaskets, removed swirl flaps and changed manifold gaskets, cleaned EGR (which was disconnected previously anyway). I still have fuel filter on my to do list.

I bought my car from a guy living in countryside and supposedly it has been remapped, so far it looks like it was remapped by someone who googled "Make my bmw e46 fast in 3 easy steps".

My suspected culprits so far for all my issues are shady remap by mr crooked fingers, injector seals or something along those lines (no major pools of diesel anywhere) or timing of the engine is off by a tiny bit.
Could even be a combination of multiple if not all of the above.

Will try to update with some pics when i get home.

Edit:I would like to add that I had no error codes besides 3 related to MAF when I had it disconnected.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Update for my troubles.

Ticking noise was not related to engine at all, it was center bearing rubber trying to divorce the bearing, it succeeded in the end so that is being changed asap along with flex disc or whatever it's called for good measure on transmission end.
Burning fuel smell was not fuel, it was my right front brakes being hungry for some brakepads.
Power issues sorted with a proper remap.

Perhaps someone has some insight on changing front wheel bearings, worth it to do just bearing for go for the whole hub ?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top