BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
started my 320d and have no speedo,rev counter,mileage etc. but the abs and airbag lights come on, all the other electrics are working ok. is this a fuse fault or something different?
 

·
Registered
Joined
·
66 Posts
Hi Nibs,

I'd check the the battery first, when my alternator went u/s on my E34 it ran for a while on the battery, the first sign of trouble was loss of mileage and rev counter intermittently, the battery warning light was on but so weak couldn't be seen in daylight even though on ignition was bright red, if battery's ok I'm sure someone else can shed some light on what else it could be.
 

·
Registered
Joined
·
85 Posts
Could be the sensor, I think they are attached to the ABS sensor hence the dash lights come on. I have had similar and had the sensor replaced and bingo. Worth a look.

Or yes, it could be a fuse. Check which one is relating to the problem, if the fuse is the same for all components, this is probably it.

Mitch
 

·
Registered
Joined
·
418 Posts
Hi I had this when driving last year, it was the rear abs sensor, thought the car had died at first, all cut out lights on, mind is blank I can't remember which side, deffenitly rear, it measures your speed and rev's I will have a look at mine to see if one sensor looks newer then the other side, I got a genuine from euro car parts, and a lot of drilling holes and knocking old one out as it was seized, hope this helps
 
1 - 7 of 7 Posts
Top