BMW Forums : BimmerForums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hey, i recently purchased my first BMW (320cd '54) and after fitting a second hand parrot ck3000 i am encountering a problem.

the CD player appears to be working on the head unit, there just isnt any sound coming out, unlike the cassette deck and radio which are working OK.

if i remove the magazine the head unit can detect this, and also detect how many tracks is on each CD. but only very quite white noise will come out of the speakers.

if anyone can help i will be most grateful....thanks
 

·
Registered
Joined
·
11 Posts
The CD changer in the boot right? When you installed the parrot, there is a seperate connection for the changer on the head. Sometimes it can become loose when you have the head unit out to fit the ISO loom. Maybe you should check the connections :thumbsup.
 

·
Registered
Joined
·
880 Posts
Usually when you install a parrot kit you add a breakout ISO cable to the radio harness. This cable only provides the main part of the radio plug. Ar the bottom of the plug are two smaller plugs (you may have 1 or 2 depending on options), you need remove these from the car harness and put them into the ISO breakout cable that connects to the radio.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
yer it is the CD changer in the boot.
you will have to excuse my lack of knowledge if i ask some silly questions...
'there is a separate connection for the changer on the head'
is that on the head unit?
when i connected it i just plugged the parrot into the normal plug on the left where the changer was plugged into.
other than two large connections, i.e. one into the back of stereo and one into conenction that is meant to go into back of stereo, there is nothing else to connection is there? like mute cables or anything?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
hey, i think i realised where i went wrong....
the 17 pin connector, at the bottom, below the round pin, is the other connection, where the two second cable goes to, like i believe richard p is talking about...

my only question is not...how do i remove this?
 

·
Registered
Joined
·
1 Posts
Same problem

As you are the only person who seems to have fixed this issue, can I ask you to explain what the problem was? I have the same Parrot unit and have just added the CD changer to my e46 320d. The CD's are recognised but no sound as you describe. How did you fix this problem, any advice would be really appreciated... can't go much longer without any music!
 

·
Registered
Joined
·
880 Posts
The radio multiplug looks like this :



The Parrot adapter is the same, but is missing the two small sub-connectors, A and B.

You must remove A and B from the car loom and plug them into the Parrot adapter so that they connect to the radio, otherwise you'll get no sound from CDC, Nav, TV, Phone or Aux.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top