BMW Forums : BimmerForums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a couple of problems with my 2003 Z4 2.5i and really can't get to the bottom of them! Any help/experience anyone can give would be great...

1) My roof operates fine, but when fully down the motor never automatically stops and the red light keeps on flashing. Am guessing there is a microswitch somewhere possible a broken one!

2) My built in Sat Nav unit rarely ever goes all the way up without error, it usually takes about 10 presses of the button before it actually goes up and stays up! Thinking about taking it out (somehow) and oiling up the stepper motor??

Just wondering if anyone has has either of these issues and has managed to fix them without an expensive dealer visit...

Thanks in advance
 

·
Registered
Joined
·
20,393 Posts
The roof should be able to have the fault codes read for it as it is module controlled, a BMW main dealer or good BMW indy specialist will be able to help you with this, :thumbsup

As for the Sat Nav question I'm afraid I don't know.
 

·
Registered
Joined
·
106 Posts
Just a thought on the roof problem; I'm not sure whether this is a problem that has just developed or whether it's always been there, but are you aware that you have to keep your finger on the button for a good two or three seconds after the roof is down to stop the light flashing?
It's the same when putting it up, to make sure it's properly locked in.

I really hope this turns out to be a cheap 'fix' for you. You may not have a fault at all.

Can't help with the sat nav as mine doesn't have one. :)
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top