BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
363 Posts
Discussion Starter #1
Bit of background here:

I have a BMW Business radio cd / nav / autochanger in the E60 - all standard but the power amp has blown in the M-ASK (head unit) - this is the audio system without the seperate amp in the boot, its a standard size head unit that all of the I-drive functions work from. So my display works, it plays CD's, radio, warning bongs PDC beeps etc but no actual audio as the amp in the unit has popped.

So, question is, is there any way i can fit seperate amps etc with the standard head unit as I may as well go for an audio upgrade than just have it repaired... How would I connect them? As i said I'm getting no audio at all from the car at present, I don't want to lose idrive functionality by replacing the HU with an aftermarket one either - anyone got any ideas?

Thanks
 

·
Registered
Joined
·
429 Posts
I don't recon so, you'll need a new / used head unit.

Check out eBay ?

You MIGHT be able to pinch the signal out some fibre optic loop if the car has one, but the cost and hassle will be impressive.

I'd source another head unit.
 

·
Registered
Joined
·
363 Posts
Discussion Starter #3
thanks for the answer, I think i can get the power amp fixed for about £100 anyway, I was just wondering whether there was another method to use the original HU as a source, though am I right in thinking that taking an amplified speaker source, that this would be a high level source and so if i was considering up-amping i'd need amps that accept a high level source over the normal??? - new to this ICE game...
 

·
Registered
Joined
·
2 Posts
Any luck with the amp/headunit as mine is doing the same thing.
 
1 - 5 of 5 Posts
Top