BMW Forums : BimmerForums banner
1 - 20 of 27 Posts

·
Registered
Joined
·
7,043 Posts
Hi Bilrosestaff :D

This photo should help you locate the MAF sensor.
You can see the Air Filter on the left of the photo, the MAF is in the middle,with an electrical plug on the top of it.
The only problem you might have is sourcing the 5 point security star bit to
unscrew the 2 screws that hold the MAF sensor in its housing?
If you were to change the housing and sensor it looks like you'll just need
allen keys and torx keys.
If you want more photo's my engine covers are off at the moment & I can post them up later this evening?

regards :thumbsup
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #5 ·
Hi
Cheers for that i took my engine cover off and i have located it as they wanted the part number, i tried to take the plug from the MAF but do you no if you have to hold the sides in or jusst pull?

Cheers Carrie
 

·
Registered
Joined
·
7,043 Posts
Hi Carrie :D

Just squeeze the two clips at the top of the plug and pull, it will come off, I've just this minute done it to mine. :thumbsup

Are you getting a new sensor or the full unit?
 

·
Registered
Joined
·
7,043 Posts
Cheers for that Slow Tech, i have brought a whle new unit. Hopefully this will sort out my long line of trouble with this car once and for good:thumbsup
Looks like an easy fit Carrie, 2 x 5MM Allen Cap head screws and 2 x T25 torx screws.
I don't know if this will help but HERE'S a blown up RealOEM drawing of the Mass air flow sensor/intake silencer.

Good luck, my fingers are crossed for you :thumbsup
 

·
BFuk Legend
Joined
·
11,712 Posts
Cheers steve23002,

Ah yes, thats why the Bosch MAF come as a unit :D
Have I been told correctly that the Pierburg '09 sensor would fit without having to recode the DDE? Is that the correct terminology???

regards :thumbsup
TBH SlowTech, i dont really know. Is the Pierburg sensor going on an E46?
As far as i know there is no re-coding needed on the E46, but I will find out for you...:thumbsup
 

·
Registered
Joined
·
258 Posts
Black smoke definitely indicates oil burning off the exhaust. Check for leaks towards the manifold in the engine bay. Also may indicate a bit too much oil if you topped it up/serviced it recently?

Also check your oil for any signs of mayonnaise - I know its unlikely but do it anyway.

Also check for leaks running down the exhaust pipes from the manifold from underneath the car. It may be easy to find.

MAF's are so easy to change and in my experience they are integral to keep clean if you want your motor to be as quick as it says on the tin.

Good luck and let us know how you get on finding that oil leak.
 

·
Registered
Joined
·
7,043 Posts
Fitted a new unit today drives perfect, just got in it and loads of black smoke started to come out any ideas what this could be. My luck and patience is running out:mad
I'm not meaning to be pedantic but are you saying the car did drive well but doesn't now it's billowing black smoke out?

or the car did drive well and is still driving ok but smoking badly?

taking into account what steve23002 has posted, is the smoke black or blue, this may give you/forum members a good indication as to possibly whats at fault?

:thumbsup
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #17 ·
Hi Slow Tech
Sorry for my misunderstanding, i have a new MAF fitted i left the garage it was perfect. I got in it again later on in the day and it starting blowing out BLACK smoke, a little shudder now and a again. It seems it may be burning fuel????
Cheers Carrie
 

·
Registered
Joined
·
7,043 Posts
Everything seems to point to it overfueling :eek but you've just had the MAF sensor and body changed haven't you?

Did you do the MAF yourself?

Does the car run better and does the smoke stop once its warmed up properly?

I know it sounds daft but have you tried unplugging the MAF sensor, just to rule it out again?

I have read somewhere I'm sure that some people have used a fuel additive after having a MAF fitted as the engine smoked, but that seems a bit contradictory to me?

Does this thread sound like your problem ? HERE, ignore the vibration bit but the post goes on to say its kicking out black smoke and another black smoke postHERE!

sorry I can't be more help, I'll keep looking and asking though :thumbsup
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #19 ·
:thumbsupI haver taken the MAF off and it runs fine, so thats what you get when you buy a pattern part. My friend has a w reg diesel and i swapped it for his MAF and it runs fine and so does his:eek Cant make it out really. All i can think of is that my one i brought is too old and his one was from a 2003 model. So we swapped them over i have his he has mine and both cars are running normal for now. I hope they stay that way.
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top