BMW Forums : BimmerForums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Got a 2003 530d sport with nav and all the gadgets.

Used carsoft 6.5 for the first time to reset the dash language from French to Uk English. Abandoned the E39 'vehicle coding' write first time round then did it again to completion. Now my language is english but the rev counter doesn't work, the mpg guage is a bit random and the OBC doesn't work.

Have tried repeating the process, guess I can't undo it.

On the bright side the language is still uk english, but there is so much else not working.

Any ideas ?

Thanks :)
 

·
Registered
Joined
·
7 Posts
Genuine or dodgy copy carsoft?
We are not allowed to discuss dodgy copies but if this is what you used and not genuine therein lies the problem probably
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks Stk,

What does the 'vehicle coding' actually write to then ? The Dash or the ECU ? I think I may have caused the problem myself by canceling the first attempt at 'vehicle coding' as I thought it was taking a tad too long.

If it is the case that I have only part programmed something can I get a generic file for whatever the 'vehicle coding' function programmes ?
 

·
Registered
Joined
·
5 Posts
Sounds like the memory dump in the cluster has been corupt. Not sure if you can read and save the cluster dump with carsoft. If you can you will need to find someone with the same cluster to get there dump file and wright it to yours. It will also need to be the same model ie auto or manual petrol or diesel. It is very straight forward to do if you know how to do it. If you change your cluster you will end up with the anti tamper light coming on.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Thanks for the info Ian and Marti.

Assuming I find someone with the same car, is there any way of doing the reprogram if I can't do it using carsoft ?
 

·
Administrator
Joined
·
4,209 Posts
Personally I'd be tempted to take it to a specialist, could save on any further damage, spending unnecessary money, and months of research!

My interpretation is that coding is turning options on or off and programming is changing the software running.

I'm getting a bit out of my depth here but if you really want to have a pop at coding you could acquire a copy of NCSExpert and give that ago. I have a basic NCSExpert guide somewhere that someone very talented gave me if you want to PM me your email address. PASoft can also do the coding that even the dealer software can't do. I think you can even set the mileage with it. You could probably pick both interfaces up for about £50.

For programming if you have wiped the software I think you will need GT1 / Progman.

Saying all this, I'd still take it to a specialist who knows what they are doing, can regulate the battery voltage etc.

I'll also PM someone who maybe able to provide further assistance.

Ian
 

·
Registered
Joined
·
5 Posts
The problam you have is its the software in the cluster/speedo is corrupt. The only way you can fix it is to reprogram it is by removing the cluster and opening it up and programing the M35080 chip. Before you even think of opening the cluster be very carefull as the motors are very very sensitive and can be broken. You would also need a copy of a dump file from the same car and a eeprom reader/writer. Even the bmw gt1 cant program this. If you send me a pm i can supply you with pics of what to do with the motors and i could also tell you who would be the best people to deal with your problam.:thumbsup
 
1 - 8 of 8 Posts
Top