BMW Forums : BimmerForums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
Today i done the pixel fix, which worked fine. When i took my clocks apart i noticed a piece of black tape over the bulb for the battery light. I took this off. Put the clocks back together and now the battery light is on when the car is running. I have only had the car a month. I have put a new battery on it. Ive have run the carsoft dignostic program and had no errors. I then run the live data program and the battery volts was 13.6/13.7. So the alternator is charging.

Any idears???
 

·
Registered
Joined
·
20,393 Posts
The alternator is controlled by the DME(ECU) on newer cars so it will be best to take the car to a auto electrician really. Otherwise it may have been to do with the rectifier on the alternator
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #5 ·
Does anyone have a wiring digram for the x5?
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #6 ·
Taken the alternator off, and had it checked and the voltage regulator is faulty. So i am having a new fitted.
 

·
Registered
Joined
·
20,393 Posts
The alternator is controlled by the DME(ECU) on newer cars so it will be best to take the car to a auto electrician really. Otherwise it may have been to do with the rectifier on the alternator
Taken the alternator off, and had it checked and the voltage regulator is faulty. So i am having a new fitted.
Winner :hihi

Cheers for the update MATTYP :thumbsup I'm no electrician but I did wonder if it was to do with the regulator, you having new alternator fitted or just regulator?
 

·
Registered
Joined
·
20,393 Posts
How much did it end up setting you back?

Also it's good to hear you reached the bottom of the problem :thumbsup
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #10 ·
£70.00 for the regulator and checking of the alternator. Thanks for all the help.
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #12 ·
Just put the car back together and the light is still on!!! Any idears???
 

·
Registered
Joined
·
20,393 Posts
Check the charge rate at the battery and at the rear of the alternator with a multimeter

Seems strange that a problem was found with your regulator but it hasn't fixed it :confused
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #14 ·
According to carsoft its is 13.9 volts, the place who repaired the alternator said every thing is fine with the unit. I have used them for years so i trust them. Dose anyone have a wiring digram for the x5?????????
 

·
Registered
Joined
·
20,393 Posts
I have no wiring for it, Boostist "may" have.

Can you access the instrument cluster with Carsoft? I see in your first post you accessed a ECU but wanted to be sure what one?
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #16 ·
I can access the dme and get live data readings, What other one do i need to access?
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top