BMW Forums : BimmerForums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi All,

New member here and recent new owner of an E53 X5 with the 3.0 M57 engine, a long winded post but wanted to give as much info as possible in the hope someone can help - apologies if this is posted in the wrong section :embarrassed

Basically I can find lots of information on getting INPA to work, but none on how to make sense of the live data in the 'analogue values' pages.....

To give some background, the car has an issue where it loses power (enters limp mode?) under full throttle and heavy load, for example accelerating up a steep hill.

It has had a full service with all filters etc, new inline fuel pump, and an injector leak off test didn't show any issues, the EGR has been removed and it doesn't have swirl flaps.

I fitted a boost gauge to see what happens with inlet manifold pressure and basically it boosts up to 1.4bar and then abruptly cuts back and wont boost again until you switch off / on again.

I have read that max boost should be 2.1bar? but not sure if this is correct?

I have tested the VNT actuator and it seems to move easily, although the car does have 140k so perhaps the vanes are sticking sometimes?

The INPA fault codes are unfortunately in German on the version I have so I need some time to try and translate them, but I was hoping someone could point me in the direction of information on the live data on the analogue values pages as I cant make much sense of them? :confused

The following values are off the scale under light throttle - "cal.limitation delivery" "1st-Air mass" "rate Main-injection"

Any help very much appreciated
 

·
Registered
Joined
·
1 Posts
Hi, I came across your post while searching for advice on buying inpa for my petrol 3.0 X5 E53. I have exactly the same issue as you and I wondered if you managed to find a solution?
Many thanks,
Howard.
 
1 - 2 of 2 Posts
Top