BMW Forums : BimmerForums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi I am new to the forum so really appreciate any help or advice anyone can give me. i have a couple of questions.. Here we go...

Just after christmas on a cold snowy day I got into my 2002 bmw 330ci sport coupe to find that my brake light,dsc light, abs lights where all on, That was bad enough but then I drove and realised the speedometer was not working. I just put it down to the weather!!. The next day my car was fine, lights where out and speedo was working....

1 week later its done it again but this time all 3 lights have stayed on for a week so far and speedometer is not working again, I was hoping it would sort itself out(how stupid I am!). I will obviously have to take it to the garage but was hoping someone could give me an idea of what the problem may be??. As I am not able to sleep over it!. Just kidding but It is a worry.

2nd question and I feel stupid asking it!. My o/s door handle has broken and I am looking on ebay for a replacement. I have seen for sale at a great price of £20 only! a BMW E46 SALOON M SERIES PASSENGER SIDE DOOR HANDLE SILVER O/S My question is will it fit my 330 coupe?? I really hope so as its the same colour as mine which will save me £££ on respraying it!!

Thank you... Michael
 

·
Super Moderator
Joined
·
12,946 Posts

·
Registered
Joined
·
6,989 Posts
The near side wheel speed sensor also controls the speedometer, to make sure you need to get the fault codes read, but one of your sensors is not working hence the reason for the lights on the dash and the speedo problem.

Go to www.realoem.com and look for your car, you can compare the part numbers of the door handles to make sure that they are the same.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Wow im impressed, many thanks for that, great help.

Any idea where is the best place to buy abs sensors? at an afforable price! and is there a particular make I should go for?

Thank you
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
E46 BMW Abs,Dsc and Brake lights still on after having it fixed!

Hi again...

Ok then I had my car checked out and code read and it came back with Abs sensors, Lambda sensor faulty.

You guys where spot on... Thank you...

Unfortunately its not all good news for me!. I have had both rear sensors fitted today along with the lambda sensor and all my lights are still on and speedo is still not working, We gave it another code read and its saying "Wheel speed sensor". I do not understand why it is coming up with that?. both sensors I had fitted are brand new. has this ever happened to anyone else?. Its so depressing...lol, and to top it off my mechanic does not have a clue what it could be now. I may just have to take it to a BMW dealer but I know they will charge me an arm and a leg!. They can have my arm but im keeping my leg!
 

·
Super Moderator
Joined
·
12,946 Posts
think your gonna need a suitable bmw diagnostics machine hook up to see where the problem lies you could have damaged wiring somewhere..
 

·
Registered
Joined
·
5 Posts
i had the same problem fitted a new abs sensor and speedo still not working and all lights on . problem was i had checked for a blown fuse and had put the fuse back in one position out from its correct position - no power to the abs ecu etc .even main dealer did nt spot the fault with their computers pluged in .then reset fault codes with a snap on ethos scanner (worth its weight in gold ) and all was well again . worth having a good look at all connections etc its not always an expensive repair
 

·
Registered
Joined
·
7 Posts
Discussion Starter #14
i had the same problem fitted a new abs sensor and speedo still not working and all lights on . problem was i had checked for a blown fuse and had put the fuse back in one position out from its correct position - no power to the abs ecu etc .even main dealer did nt spot the fault with their computers pluged in .then reset fault codes with a snap on ethos scanner (worth its weight in gold ) and all was well again . worth having a good look at all connections etc its not always an expensive repair
Thanks for that, I had another code read, I have been told now its the ECU- (abs pump) that is at fault. To buy a new ecu is £500. I am going to look for a decent used one instead!!.

I have been trying to find the part no for the ecu at:
http://www.realoem.com/bmw/select.do?vin=JU64128

but cant find it!!. I have put in the last 7 digits of my Vin(JU64128). Its so complicated if your a little simple like me!.

Can anyone please help me with the correct part number I need?.

Thank you....
 
1 - 14 of 14 Posts
Top