BMW Forums : BimmerForums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 · (Edited)
Hi guys,

So as it says really, i noticed i was loosing a little coolant after a warning light came on, and it looked like there was a leak from around the top of the expansion tank.
I brought a new expansion tank, rad cap and level sensor and set about doing the job. I took the car apart and removed the old expansion tank as i had heard they are prone to splitting, and it still had the original BMW label on from new so i thought okay, it's bound to be that as its been there since the car was new.

I fitted the new tank, connected everything back together and topped the coolant system back up and bled it but i noticed that i still seemed to have a leak. It now looks like it is the smaller of the two connectors on the top rad hose connection (the rigid plastic part that fits to the rad and the tank). I took this back off and it looks like where there should be an o ring or similar, there is not!

Does anyone know if this is a case of fitting an o ring, or do i need to fit the whole new hose assembly, and also does anyone know if this is a common failure?

Also i now have the engine check light illuminated. I guess this is because ive unplugged the sensor on the airbox when i removed it?? IS this something that will go out on its own, or do i need to have the memory cleared?

Any help appreciated

Cheers Russ
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #4 ·
Ronnie,

It doesnt look like there is "much" of an o ring in the smaller port on hose number 1, and this is where it looks like it is leaking from, but i cant find any detail as to what should go be there?!? This hose is original to the car and has not been changed.

Management light has now gon eout on it own so thats one issue resolved, i just need to know what should be in that pipe, and if it is an oring, can i buy it or do i need the whole pipe assembly?

Cheers for the reply
 

·
Registered
Joined
·
20,393 Posts
The O rings don't come separately, they come with the pipe and should be inside the pipe itself, if you do have one missing then you will need a new pipe.


Have a good check to be sure :cool
 
1 - 5 of 5 Posts
Top