BMW Forums : BimmerForums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
Hello for the last year my car had a delayed start, I would put it in the 3rd key position nothing would happen for 3-5sec then the car would start normally. It went away during summer. But with cold weather approaching it has been getting worse. Sometimes it takes few minutes before the car cranks. Weird thing is after it cranks its starts immediately. No hesitation whatsoever. I also noticed there is a click coming from the engine bay every time I turn it to 3rd position. Battery is fully charged not problem there. Maybe there is something stuck in the starter and gets loose after few tries?
 

·
Registered
Joined
·
11 Posts
could be the starter, more precisely the starter contactor, best would be to take the starter off and rebuild it...
 

·
Registered
Joined
·
51 Posts
Discussion Starter #3
ill probably get another one used. Cant be without car that long. Anyone got any guide about starter replacement? I know how to do it on gas ones but never done diesel. tbh I dont even know where the starer is located.
 

·
Registered
Joined
·
2,119 Posts
YouTube should help you on the starter change but first check the earth to the engine.
Even try a jumper cable from the jump point earth and clip on the engine to see.
 

·
Registered
Joined
·
1,213 Posts
Most of time is to check starter solenoid. Like many others Bmw cars diesel or gas starter is located at left side ( view from inside car). And most of time you have to take off intake.
 

·
Registered
Joined
·
8 Posts
Looking into the engine bay it's on the right side, you'll have to remove the intake and cabin filters and you'll see it right at the back. It's difficult to get spanners into and I had to make a tool to get the bolts undone. It's a simple job but very tight. The starter has 2 bolts holding it in and then there's a few nuts for the cables.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #7
I did more research about this, and found more solutions. First I will try second key if maybe the immo chip is dying. Another one is ignition switch. I replaced my few months ago but used the cheapest brand I found so it might be gone again. I opened the original one cleaned all the contacts and if the key wont help I will try putting it back. If all this fails then will check the EWS relay. After that starter
 

·
Registered
Joined
·
51 Posts
Discussion Starter #8
OK I replaced the ignition switch back to the 18yr old one which I just cleaned inside. And so far for 2 days its starting normally. Hopefully it stays like that :D
 
1 - 8 of 8 Posts
Top