BMW Forums : BimmerForums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi every one I have a 02 318 coupe that has an odd problem in that the battery light will flash on and some times at the same time the engine will cut out ! It usually only lasts for a second and usually on the motorway 3k-5k rpm ( not usually on bumpy road so don't think its lose connection) this problem can go way for weeks then up back again do it once or 2 times in a row , there's no sense to it . Any help greatly appreciated . Steve
 

·
Registered
Joined
·
169 Posts
Without people just guessing at the cause Steve might be a good idea to get your codes read.

If you haven't a code reader (BMW specific) then a good Indy would be your best bet rather than the local garage.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
e46 battery light

Hi I should have said I took it to BMW and they told me there was no fault ? They remapped the engine (if thats the right term) and as I say it can be fine for weeks then it will happen , having read through the forum people have pointed the finger at the cam sensor for similar problems, thanks steve
 

·
Registered
Joined
·
320 Posts
All the ones I have had with this fault have been the cranksensor mate, hope this helps. They do not always store faults.
 

·
Registered
Joined
·
229 Posts
All the ones I have had with this fault have been the cranksensor mate, hope this helps. They do not always store faults.
it will be the crank speed sensor as that was exactly the problem i had,
best to fit a genuine one as it will be long lived.
 

·
Registered
Joined
·
169 Posts
Just to add - literally a week ago my car started cutting out (I started a thread on it). Symptoms were a bit different though, the car would stop and it'd take a good few spins to get it going. It'd go for 50 metres then stop. Finally got it home and the next day it started and ran fine - when I read the DME error codes it stated plain and simple 'crankshaft sensor'.

Replaced it and it's been fine since.

Don't think the cam sensor would cause it to stall, I've just replaced mine but that was for some rough idling.
 

·
Registered
Joined
·
1 Posts
2004 318 battery light flashes on,Intermittent cutting out

Hi,

Im having exactly the same issue. I had the crank sensor recently replaced but the problem is still there and is now getting even more frequent. Im now confused, where should i be looking cam sensor or crank speed sensor. Any help would be appreciated. Thanks in advance.

Shahbaz
 

·
Registered
Joined
·
229 Posts
Hi,

Im having exactly the same issue. I had the crank sensor recently replaced but the problem is still there and is now getting even more frequent. Im now confused, where should i be looking cam sensor or crank speed sensor. Any help would be appreciated. Thanks in advance.

Shahbaz
#

i would get the fault codes read .
 
1 - 9 of 9 Posts
Top