BMW Forums : BimmerForums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hello folks. Looking for some advice and guidance please. My engine light has come on and the fault code is suggesting pre cat lambda fault (code 125 I think!?). It was previously intermittent but is now on constantly even after having the faults cleared etc.

Is there anything else that may cause this fault that I should check before splashing out on a new sensor? Sensor is an easy fix but still £60 ish quid so I'd rather check all possibilities.

I have got Carsoft so can post shots of the live readings if that will help at all?

Thanks in advance.:thumbsup
 

·
Registered
Joined
·
20,393 Posts
code 125 is Pre cat Oxygen sensor, open circuit or short circuit to battery or short circuit to ground.

Check the wiring out but otherwise it will be the sensor, hows the MPG?
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Not good MPG would be my opinion Ronnie!! Averages 30MPG combined, mainly country roads and not hard driving, but still it's a 316 1895cc so I would have expected more to be honest. I'm guessing bad MPG is a sign of a faulty sensor? Would you say 30 is quite bad?

Is there anything to look at in the live data that would give me a clue?
 

·
Registered
Joined
·
20,393 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Thanks Ronnie. Appreciate your help. Any advice on where I can locate the wiring connector for the pre cat Lambda? Finding the sensor was easy but just not clear on where the connection is.

Cheers
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #8 ·
Thanks Neal, appreciate your help. Should be easy enough to find as it is only 370mm away from the actual sensor. Out of interest what does it actually plug in to in the engine bay? The ECU?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top