BMW Forums : BimmerForums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
First, let me say - I did search this forum and read related posts, but have not found similar simptom / solution. -

(a) When the car (316i, 2002, E46) has been parked for a while, I start it and reverse - my Parking Sensors are working fine.
(b) After a short drive (5-15mins) - they are still working fine.
(c) After a long drive (15mins +) - when I park/reverse, very often (but not always) I get frequent beeping, like there is an obsticle very close behind.

(d) I did check sensors, by switching key in position 2 and listening - all sensors are 'ticking'.
(e) I did wipe them off and tested - still beeping (when reversing after a long drive).

What could it be? :cool

P.S.One of suggestions (from previous 'parking sensors' questions) was to check if sensors are properly sealed. How is it to be done? Does it mean - to actually crawl under the car, behind rear trim and feel/touch sensors, or what?
 

·
Registered
Joined
·
20,393 Posts
You will need to check the PDC sensor plugs are firmly home and the connections are clean, otherwise get the fault codes read for the PDC, will also be worth checking the boot hasn't got water in it
 

·
Registered
Joined
·
2 Posts
Hi , I have exactly the same problem, on startup most of the time they are fine, then after a bit of a drive, when put into reverse they just either have a very fast beep, or the continuous beep.

I've listened to them with the ignition on, and they all tick over nicely, on one of them though it seems like there's a tiny bit of flaking paint?? Also I have used a power washer on them.....:confused

Thanks
 

·
Registered
Joined
·
2 Posts
Thanks Guys especially Sam1832 for his excellent guide.

A BMW garage confirmed the faulty PDC sensor with their diagnostics, also I could tell it was giving faulty signal by moving close up to it and moving away, and listening to the tones. All 4 sensors were ticking. But this was giving random beeps/constant tone!

I've just fixed it today. I got the spare part off ebay for £20, and using Sam1832's E46 sport rear bumper removal guide, 2 hours later with help from my friend we changed it, everything works great now!!!!! Annoying Mudguards and tool shopping slowed us down!

Best regards,

SH
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top