BMW Forums : BimmerForums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 52 plate 318ci cabrio that has just started stopping when it feels like it. It is as if the engine has stalled but I cant restart it straight away. It only happens on low revs & even then is very sporadic. When it stops the handbrake light comes on along with the traction control light. My mechanic has tested it but nothing shows on the engine management. I have just had an mot & service & had the handbrake replaced. Any ideas anyone?
 

·
Registered
Joined
·
1,151 Posts
I have a 52 plate 318ci cabrio that has just started stopping when it feels like it. It is as if the engine has stalled but I cant restart it straight away. It only happens on low revs & even then is very sporadic. When it stops the handbrake light comes on along with the traction control light. My mechanic has tested it but nothing shows on the engine management. I have just had an mot & service & had the handbrake replaced. Any ideas anyone?

Do you mean your mechanic had the car scanned and now error codes came up?

Do you know what type of scanner he used mate?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
yeah its been scanned. showed up that the sensor on the camb shaft exhaust had gone but had that replaced & it broke down again!! anybody wanna buy a cabrio!!!!!
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top