BMW Forums : BimmerForums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hey all , right let me take some time to explain this

my rear handbrake shoes had fallen away from the dust shields due to excessive rust on where the mounting pins go (more round now that square)

so i decide to get some new ones from bmw only £13 pounds each

i know for these to be replaced i have to remove the hubs so i called on a good friend who knows his cars quite well and he has a hub puller . the hubs come off ok and all going ok

we put the right side all back together all ok no problems

now this is where the problem is the left side (near side in the UK) when we are trying to line up the rear drive shaft and get the hub back on the drive shaft will only turn one way and cant seem to get to line up correctly to the hub all shafts were fine before we started job .. any one know what we may have done or are we doing something stupid ?

right side is fine left side is the issue

Cheers All - all this for a bloody handbrake !!!

Regards

Dave
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
right bit of an update .. it turned out not sure how that the nearside output shaft was broken one of the balls in the outer join had play which was resticting movement. i ordered a second hand replacement from parts gateway (with 90 days warenty) all has gone back together ok now all the wheels back on and for the first time in a while we took it for a test drive .. all now driving ok how ever there is a slight rumble from the nearside rear which is of course where the replacement output shaft is .. now my mate who is kindly helping me with this seems to beleive its one of two things .. the wheel bareing has been damaged or where we been working got worst and maybe on the way out or it could be the replacement shaft is not as good condition as we had hoped ... the other idea someone else has if this shaft has been sitting for a while the grease may take a while to thin up a bit ? its quite a low rumble ....

oh and by the way :) my handbrake is now working great ha ha ha ha ha

Dave
 
1 - 8 of 8 Posts
Top