BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi there i am new to the forum and need some advice, my e46 330 petrol has started taking alot longer for the oil pressure light to go out when the car has been stood for a while as if the oil is draining out of the filter housing i have changed the filter and the two orings on the shaft but it is still the same what i want to know is there some type of non return valve in the system which could be stuck open or something else which could cause this fault thanks adam.
 

·
Registered
Joined
·
20,393 Posts
Red or yellow light?

Also could you please remember to add the vehicle details and a informative title in the Thread Title next time as per forum rules please http://www.bimmerforums.co.uk/forum/...ement.php?f=69, the Thread title has been done for you this time. It makes it far easier for people looking up help for their own problems or conversions if they have the same car.
 

·
Registered
Joined
·
20,393 Posts
You should get a oil pressure test performed, :thumbsup

If you are lucky it may be a bit of "swarf e.t.c." that has got stuck under the pressure relief valve.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks for that, regarding my first post what holds the oil in the filter bowl is there a nrv or is it simply the orings the reason i say this is because if the car is started from cold and only run for a few minutes then the following morning the light goes out straight away which is telling me the oil is still cold and thick, the fault only occurs when the engine has had a good run and then left a while.
 
1 - 7 of 7 Posts
Top