BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
501 Posts
Discussion Starter #1
had a leaking oil filter housing gasket on the 325 and it was only leaking slightly and the car was still quick but after having replaced the gasket and now no more leaking the car seems to have gone mad!!

Before it used to pull and keep going but now it just seems to pull and pull with so much grunt!!

In first gear traction control on before the traction control would only kick in slightly in a straight line but now floor it from 3.5-4k and the traction control goes mad and the cars tries to snake and its got soo much grunt, the revs just go on and on.

is it just me or am i right in thinking that the car has actually picked up some lost power after changing the housing gasket as now there is enough pressure etc and the vanos is working correctly..... therefore getting use of it full power?
 

·
Registered
Joined
·
501 Posts
Discussion Starter #3
whats the adjuster unit?
I dont think theres a problem just that it feels a lot quicker and has more grunt but would a gasket change really make that much difference?
 

·
Registered
Joined
·
501 Posts
Discussion Starter #5
oh right. guess il have to have a look tomoroow or something but what problem would that give if it isnt working correctly?
 

·
Registered
Joined
·
501 Posts
Discussion Starter #7 (Edited)
nooo i said that i seem to have a lot more grunt than before now that the leaking gasket has been changed.
before the car was still pretty quick but now it seems to wheelspin a bit and get the traction control kicking in first gear a lot more than before. What i wanted to know is if changing the gasket has actually made that much difference in power.
 
1 - 7 of 7 Posts
Top