BMW Forums : BimmerForums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
1,151 Posts
Discussion Starter · #1 ·
Hi Guy's,

My Coupe ran into a few probs 2day and was wondering if anyone has ahad any similar issues.

basically, driving along, the abs, eml and traction control light's came on but drove ok. Switched the car off and back on and the lights went out.

This went on at leat once a day until about an hour ago where the lights came on but this time the engine check light came up and all and I was not able to rev the car up...........floored the pedal but got almost no power at all, managed to crawl home.

I plugged in my EOBD reader and it broght up 3 codes:

P1634 - Throttle Valve adaptation: spring test failed

P1501 - Idle speed control valve stuck closed

P0014 - B Cam position

I reset the codes, fired the car up, the engine checl light went out but the other 3 lights were still on and still no power when gas pedal was pressed.

I re-read the codes and got a pending code of:

P1643 again.

can anyone shed some light on this please? I am thinking that my throttle body is buggered as I have seen these fail but would like a second opinion.

Any help would be much appreciated.

Thanks.
 

·
BFuk Legend
Joined
·
11,712 Posts
Ive got some test procedures on my pc for these Ray. :thumbsup
The only prob is that ive got the BMW codes on here not EOBD. :frown
Ive had a look and the closest description comes up with
175 Throttle Valve control unit - Adaptation Error
Looking at it they have two position sensors :eek

I cant copy and paste from my Diag machine but ill try and print the pages off and scan them in so you have the voltages, etc if you want
 

·
Legendary BFuk Member
Joined
·
12,959 Posts
Ray is the E46 on a cable like the E36?

If so have you tried operating the cable from within the engine bay. It sounds to me like the throttle is not opening under pedal operation:confused

You've probably already checked/eliminated this but just a thought mate:thumbsup
 

·
Registered
Joined
·
1,151 Posts
Discussion Starter · #7 ·
Ray is the E46 on a cable like the E36?

If so have you tried operating the cable from within the engine bay. It sounds to me like the throttle is not opening under pedal operation:confused

You've probably already checked/eliminated this but just a thought mate:thumbsup


No cable dude:frown

bloody fly by wire.

I've looked into this further...........looks like the Throttle body f'ing up is pretty common, may well be looking at a replacement housing..........160 squids from ECP:frown


CHIT MAN!! 160 squids!.................sigh: could get my nails done AND my Jerri-curls revived for that..............shizer!!
 

·
Legendary BFuk Member
Joined
·
12,959 Posts
No cable dude:frown

bloody fly by wire.

I've looked into this further...........looks like the Throttle body f'ing up is pretty common, may well be looking at a replacement housing..........160 squids from ECP:frown
So am I correct in thinking that if the inlet manifold was removed the throttle body flap is not opening when the accelerator is operated?:frown

My E36 diesel is fly by wire and I'm not sure how it functions:confused
 

·
BFuk Legend
Joined
·
11,712 Posts
No cable dude:frown

bloody fly by wire.

I've looked into this further...........looks like the Throttle body f'ing up is pretty common, may well be looking at a replacement housing..........160 squids from ECP:frown


CHIT MAN!! 160 squids!.................sigh: could get my nails done AND my Jerri-curls revived for that..............shizer!!
£160 :eek

I dunno what was wrong with a cable doing the job :frown

Did any of that info help Buddy?
 

·
Registered
Joined
·
1,151 Posts
Discussion Starter · #12 ·
Sorry, I gathered that:hihi

I was asking if yours is opening and closing during this problem:rofl

:thumbsup


:rofl:rofl

My bad!


Update:

put the car on the scanner again after resetting from last night.

Got the P01643 code. cleared it.

Fired the car up and then immediately kicked out a P00014 code, "B" cam sensor.

This is the second time since last night this code came up and now it came up on its own. Knowing what the cam sensor failure can do i.e car not revving up..........I replaced it with one that I had lurking around.

Reset the codes, fired the car up and it seemed to idel alot better and throttle is more responsive and car was again revving up fine.

No other warning lights or codes have come up so far.

But I do still think I have a problem with the Throttle body since the speeds sensors do pick up data from the throttle body and since they went down a few times and from what I know of these throttle body faults- further investigation is needed.

So, it looks like....hopefully, I had 2 faults going on:

Cam sensor and the throttle body issue.

Steve, your info aint worth jack shit!!

:rofl:rofl:rofl:rofl

...........just messin!:rofl

Great info mate, thanks dude:thumbsup am gonna use it to test the throttle body and the related components 2moro.

Rym, will check everything out 2moro and get bacl with an update.

cheerz guy's.
 

·
Registered
Joined
·
1,151 Posts
Discussion Starter · #14 ·
You not got a BMW specific code reader Slack? those EOBD codes are rubbish!

You will find out alot more with the proper BMW codes.


True.

We personally don't have an autolgic BMW system but am gonna see my matey on monday who does.

Will get the codes read again and report back.

but ever since changing the cam sensor, all has been fine with performance. bur still, occasionally, get the abs and traction light come up.
 

·
Registered
Joined
·
20,393 Posts
True.

We personally don't have an autolgic BMW system but am gonna see my matey on monday who does.

Will get the codes read again and report back.

but ever since changing the cam sensor, all has been fine with performance. bur still, occasionally, get the abs and traction light come up.
Won't need to be a Autologic, we have a cheap Omitec like this http://www.omitec.com/en/products/omiscan/, but it does dealer codes :cool, good for what it is(door stop) :hihi

Let us know what you find :cool
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top