BMW Forums : BimmerForums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hi there,

1st post and looking to purchase my 2nd BMW. (upgrading from a 91 petrol)Looked at a few today and i 'think' i've finally decided on a nice looking racing red one only im not sure if i should be put off.

Should i be put off with 145k on the clock for a diesel?? The guys looking for £3900 and im just not sure if the milage should put me off. Also on the test drive i noticed the airbag light stays on? Any idea's why that would be?

Any advice would be appreciated!
 

·
Registered
Joined
·
1,240 Posts
there are threads all over the place about the airbag light, it could be one of a great many things. occupancy sensor, seat belt pretensioner, wiring fault, duff airbag, the list goes on. Any auto electrician worth his salt will have the kit to not only reset it (if the fault can be reset), but also tell you exactly which component is playing up. In the short time I have owned my beemer (2 months?), the seat belt pretensioner has thrown a fault llight up twice. both times reset under warranty. Its worth insisting he clear the fault or pay a travelling autolecky dude to come and sort it before you buy it. Some of the components that can cause the light are not only expensive to buy, but a royal PITA to fit.

Resetting it is literally a 2 minute job with the right tools for the job.
 

·
Registered
Joined
·
143 Posts
Sounds a lot for the year and miles to be honest, I have a 2003 with 109k and wouldn't expect much more than what they're asking for if I were trying to sell it.

The older 136bhp pre-facelift model was more reliable than the 2002-2003 150bhp 320d so you should be ok for reliability if it has FSH.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #7 · (Edited)
2001 E46 320d se model - **BOUGHT** Advice needed

Well im now the proud owner of a 320dse

Bargained him down to £3350 so im happy with that. She's lovely! :D Few questions but.....

When i put reverse on, i get one long single beep. Am i right in saying the parking sensors kaput?

Theres a slight clicking noise when i turn the steering wheel either direction. You can't feel anything, but theres defo a click. Any ideas?

When i start the car, the oil symbol comes on yellow for 5 secs and goes off again. Oil level seems fine, so am i right in thinking this could be just the oil sensor being faulty and as long as i keep an eye on the oil level nothing to worry about?

With the automatic air conditioning whats the best default setting? Leave it on auto or am i actually ok to have it switched off?

One final question.... its got a hands free mobile holder but looks to hold a prehistoric phone. Is there anyway to get this adapted for for nokia n95 or if not an easy way to remove it?

Thanks in advance!
 

·
Registered
Joined
·
1,240 Posts
oil light? the fact it goes out would be enough for me to ignore it. Though initially I would be in headless chicken mode and check my levels.

one long beep in reverse sounds like something is wrong with reversing sensors (provided they are actually fitted and it isnt some daft idea that Toyota use, the celica beeps whenever the car is in reverse despite there being no parking sensors, it's apparently because the gates of the 6 speed box are so close together that it is easy to select reverse in error. Personally I think it is because its a girly car).

Automatic climate control. Set it to what suits you. 18.5 is a good means figure. not too hot, not too cold. As with any form of aircon though, leaving it off permanently gives rise to problems later in life. Regassing being a big one for those who dont use it and want it later.

Personally I leave mine on at 17 all the time.
 
  • Like
Reactions: gazman999

·
Registered
Joined
·
2 Posts
guys,the yellow oil symbol is a very common fault and nothing to worry about.
it will be a sensor fault as ive had the same problem.my advice is unless its annoying you, you might aswell wait until its due its oil change until you replace it,the link shows it location on the sump, 2 or 3 bolts i think.this is the website i picked mine up from.not sure if its the cheapest around but it did the job for me.
http://www.c3bmw.co.uk/StockItem.as...roductID=1795&oRef=-1&section=2&Item=unassign
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #12 ·
Congrats on buying your BMW. :thumbsup

One long single beep from the oem parking sensors usually means they are malfunctioning. But try to clean the sensors first if they are dirty before trying to change them.
Thanks! I really do love it!

I was thinking tho about the parking sensor. Would the malfunction be caused by the tow bar sticking out the back of the car :duh
 

·
Registered
Joined
·
1,028 Posts
I have the same year car as yourself and i hope you enjoy it as much as i have. Mine has done 181k and still feels like a new car. Just keep it serviced at regular intervals. I keep the heater on auto set at 18 most of the time seems to work best. The long beep happened to me with the reversig sensors but a good clean sorted it out. I would of thought the tow bar would keep the beep continious.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #15 ·
Did you manage to figure out the clicking noise on your steering. I'm experiencing the same?
No, didn't get to the bottom of it. I removed the towbar and still getting the beep.

I did notice that none of the sensors click and there is one thats slightly pushed in. I'd need to remove the bumper to get at it but i don't know how. lol.

So at the minute i'm just living with it...... and enjoying the car!!
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top