BMW Forums : BimmerForums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have just purchased the above 2001 convertible with the Harman Kardon radio system.

The system works okay but the front left hand speaker makes a hissing noice whenever the ignition is in the I position i.e. power on.

With the ignition in the off position and the radio on, no hissing.

Anybody come across this before ? and any advice on how to rectify.

Thanks

Simon
 

·
Legendary BFuk Member
Joined
·
12,959 Posts
Where are the speakers located in the front of your car? Are they in the foot wells or the doors?

If they're in the doors then my first check would be the wiring that runs through the doors... wires that are constantly moved (Doors opening/closing) are subject to becoming weak. The plastic protective sheath breaks exposing the metal wires and can allow them to touch other damaged wires:frown

You could try swapping the front speakers over, If the noise then transfers to the other side you know it's the speaker and if it continues to do it only on the left then you know it's wiring related or possibly a channel down on the head unit?

Does this vehicle have an in built amp? Could be another factor:confused
 

·
Registered
Joined
·
1 Posts
Hi

Sorry to dig up an old post here, wondering if the problem was resolved as i have the same thing.

On my clubsport with HK, the hissing/static appears to come from the FNS speaker(s) and is always on regardless whether the radio or CD player are on, and isnt affected by volume. it's a consistent hissing that i cant get rid of until the ignition is off.

Any help greatly appreciated.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top