BMW Forums : BimmerForums banner

1 - 20 of 32 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
as the title says my injectors are not injecting fuel into the inlet, i know theres fuel at the rail, i was wondering what controls the fuel injectors cheers
 

·
Registered
Joined
·
117 Posts
Discussion Starter #3
No other immobiliser just the standered one, would a faulty sensor or relay cause it not too inject fuel, also there is a fuel leak on the pipe that connects to the fuel rail, the screw one, but only very small so i dont think this would cause it not to inject would it
 

·
Registered
Joined
·
8,981 Posts
No other immobiliser just the standered one, would a faulty sensor or relay cause it not too inject fuel, also there is a fuel leak on the pipe that connects to the fuel rail, the screw one, but only very small so i dont think this would cause it not to inject would it

I'd get that fixed first. So the engine turns over OK? Any signs of spark from the coilpacks?

If you are getting a spark, then the ECU isn't cutting the fuel on purpose.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #7
Checked all the fuses there all ok, there is a spark, it nearly started earlier as i took all the injectors out and when i turned the ignition fuel splilled out into the manifold, so when i tried starting it up again it nearly fired. So i know its not injecting fuel i just dont know whats causing it not too. The way it died was like it ran out of fuel, but it had fuel in it. But i have been playing with the electrics as my window wipers have never worked properly but i have checked all the wires and cant see anything out of place.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #8
Has anyone else got an idea of what could stop the injectors from working, everything else works fine, its sparking ok.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #10
Do you think it could be a faulty ecu, i know the engine management relay is working cause i can hear it clicking when the engine is cranked. So i need to know what controls the injectors and what could cause them to fail, the fuse is deffinetly ok i checked earlier.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #11
Is the fuse for the injectors located next to the ecu, also where is the earth for them, how do i test to see if my ecu is knackered, and do they just work from putting a positive and negative to the injector. Any advice is appreciated thanks
 

·
Registered
Joined
·
117 Posts
Discussion Starter #13
Its going on a diagnostic when i can find one who will come to my house, do you think its the ecu then thats knackerd then if thats all that controls the injectors, or is there a sensor that could have failed, is there a way to fire the injectors manual to see if they work
 

·
Registered
Joined
·
248 Posts
Did you post on the electrical forum?

Did you say the inj fired fuel?

And you have a spark?

If you got both then the engine should run. Maybe the engine has flooded. If they do they are a pain to start. Put your foot flat to the floor and crank, and crank, and crank........

Keep going until she fires, on 1,2 then maybe 4 cylinders.

If you remove a spark plug does it smell of fuel?
 

·
Super Moderator
Joined
·
12,946 Posts
a burst of bradex easi start might coax it into life but its valve burning evil stuff just dont use a lot of it for too long..

or warm the plugs in an oven before fitting em with gloves on used ta work on troublsome starters years ago..
 

·
Registered
Joined
·
1,949 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #18
i have a spark but the injectors arent firing but i did have a leak where the fuel line went into the injector rail but ive cured that now but it still doesnt start so i think it is something electrical.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #20
i tried replacing the crankshaft sensor tonight, but it was such a pain in the arse to get at the allen key bolt. Is this really likely to cause it not to inject fuel and would it just pack in instantly, i thought they go slowly, how do i know if my ecu is getting power cause i disconnected it earlier and nothing changed the car still turned over so i think it may have packed in or not getting power to it.
 
1 - 20 of 32 Posts
Top