BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi Everyone - this is my first post, so I have undoubtably got something wrong already..........

Bought a mid mileage E46 for my better half so she could have reliable quality motoring.. sadly not.

After replacing front suspension and just about every component of the cooling system (parts had good manners to fade sequentially), its overall performance is now deteriorating rapidly.

Starting always good, but try and accelerate when cold it's like driving into blancmange. It will slowly stagger up to almost any speed you want - as long as there are no hills...... Any attempt to accelerate brings on the party-food feeling again. Improves margainally when car is warm.

Fuel consumption OK, plugs look OK and similar to each other.

But - engine light has been on since I bought the car; BMW specialist claimed it was a crankcase breather valve, which was replaced. Light went out until I was off the premises.

Any ideas - or is it off for another £60 diagnostic check?

Thanks for reading this - HughD
 

·
Registered
Joined
·
183 Posts
Sounds like the specialist just cleared the codes with the fault still present.

Any chance you can get the engine fault codes read and post them on here?

Is the engine code N42B20 or M43?
 

·
Super Moderator
Joined
·
12,946 Posts
favorite candidate is the MAF but it needs scanning with bmw software aswell i think and iterpreting by somebody who knows what they are lookin at for any other underlying issues...

is it an M43 or N42 engine?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Thanks for the help with this - advice encouragingly consistent!

It's an M43 motor - I did my best to keep things simple.

Will post codes when I have them!
 

·
Super Moderator
Joined
·
12,946 Posts
M43 is notorious for duff MAF's they are expensive aswell cos itsa common failure..


try drivin it for a few miles with it unplugged see if it behaves any better?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Thanks Dailydoggy..

Removed my MFA sensor and gave it a good seeing to with isopropyl alcohol - car back to normal!

Now I have to find out why the engine light won't go out - so it's back to my Diagnostic Elf (unfortunately won't accept payment in magic beans)...


PS Great introduction to the forum!
 
1 - 7 of 7 Posts
Top