BMW Forums : BimmerForums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
My car is 2001 530d E39 auto touring.
When you first pull away especialy when cold good power all through range from 1500.
After it has changed up there is little power below 3000.
Stop switch off ignition, restart good power.
This work until the engine gets warm then reverts to little power below 3000.
This applies in any gear mode and kickdown.
If you stop for a while it does back to god power until it changes gear.
The engine starts well, does not misfire and does not smoke.
Fuel consumtion is about 26 around town and a quick 0-60 time around 9sec (when full power)
All the faults have been cleared and rechecked three time. Non returned.
The only major fault was the gearbox not talking to the ABS/Traction control.
This had accured a lot of times in the past but after clearing the fault has not returned.
I have had gearbox go into safe mode for a short time, but this did not show on the diagnostic check.
 

·
Registered
Joined
·
20,393 Posts
I would try disconnecting the MAF(Mass Air Flow meter) while the car is running when the car has gone into its "slow mode", this will make the DDE(engine ECU) run on some default settings, if the car goes better then I would get a MAF for it.

Other choices are taking the car to a good Auto electrician so he can view the live engine running data and see which components are out of spec.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
I drove to London with the MAF conected, then drove home with it disconected,
Thye low down pick up is much better and the fuel consumption increased by 2mpg.
the down side is with it disconected the top end power is down.
0-60 with it connected 9.1 sec disconected 9.7 sec.
I think I will change the MAF anyway
Graham
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I have fitted a new flow meter (527) Bosch. the one I removed was a 468, so I presume the coding should be correct.
It has not made much difference. still good low down when cold then nothing below 3000 when warm. It feels like it is to weak on fuel.
Is there other temperature senders. I do not think it is fuel pressure because it does so well at the top end, but it may be the enriching device under turbo pressure. Again if I disconnect the MAF the power is good low down.
Still nothing on the computer.
Any ideas.
 

·
Registered
Joined
·
20,393 Posts
You may need to get the faults cleared and the adaptations reset, I recall a member who had the same problem and was only successful once this was done.

The temperature sensor is shown here
View attachment 2596

It will show up in the live data on a scanner if the sensor is giving incorrect signals
 

·
Registered
Joined
·
4 Posts
525i 2001 e39 106k

Hi,
My 525i has recently developed similar symptoms. i.e. gearbox goes into safe mode. If you stop the car and restart the engine it clears the fault and the car drives normally for a while.
This fault only happens when I’m stationary or at low speeds. On a few occasions the ABS light has come on, together with the yellow warning triangle. When this happens, the Speedo stops working ( not the rev counter) However if you continue driving after a while the ABS warning lights goes off together with the triangle and the Speedo starts working again. The gearbox light remains on and the car stays in safe mode.

One other point I’ve noticed is that, if you stop and clear the fault by restarting the engine and continue on, the fault will comeback more quickly each time.

I have had the codes read and the Indy i used has replaced a temperature sensor replaced. He’s coming again tomorrow to read the codes again.
 

·
Registered
Joined
·
20,393 Posts
Have the fault codes been read using a BMW specific scanner? If not then this needs doing. Get the engine, transmission and ABS/Traction control codes read.

G Wattons car fault was traced by blowing some smoke down a couple of the vacuum pipes and looking out for any escaping.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top