BMW Forums : BimmerForums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Hi,

I have a problem with one of the ECU plastic housing bolts shown here for friend's car.

http://www.realoem.com/bmw/showparts.do?model=AL32&mospid=47631&btnr=12_0899&hg=12&fg=35

Part 6

It spins freely with a clicking sound and will not come loose. It tightens OK. I am trying to remove the bolts to gain access to ECU. All other bolts are OK just this one.

Tried WD40 which is getting in and also easing it from side to side, tightening, loosening etc but nothing is working. It hasn't seized as it is moving with the clicking sound.

Any ideas please would be much appreciated.

Thanks in advance, L :thumbsup
 

·
Registered
Joined
·
29 Posts
Discussion Starter #3
Hi, thanks for quick reply its sitting in its fully screwed in position clicking. Can't get it to lift up at all without risking cracking the plastic housing from what I can see.
 

·
Registered
Joined
·
6,989 Posts
It sounds like there might be a captive nut somewhere that is no longer captive and turning on the plastic.... Can you remove the other screws and use the lid as a lever against the bolt keeping a little pressure on it so that the nut doesn't turn in it's housing?

Not too much so as to damage the lid though mind...:thumbsup
 

·
Registered
Joined
·
8,981 Posts
If it turns a full revolution, then clicks, it is loose, and you just need to pull up on the lid.

It should spin very freely, and the bolt is also captive so it won't fall out of the lid.
Once both (check for more too) are spinning freely, just try yanking that lid up.

There is the possibility that the threaded insert it bolts into has come loose, but unlikely from your description.
 
1 - 6 of 6 Posts
Top