BMW Forums : BimmerForums banner
1 - 20 of 33 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hello, i have a x reg 318 ci and the emissions light has come on, i use a mac tools code reader and it has read the code p0170 Fuel Trim Malfunction (Bank 1) has anybody had this fault or anybody know how to tackle this problem?
many thanks
stephen
 

·
Registered
Joined
·
1,151 Posts
hello, i have a x reg 318 ci and the emissions light has come on, i use a mac tools code reader and it has read the code p0170 Fuel Trim Malfunction (Bank 1) has anybody had this fault or anybody know how to tackle this problem?
many thanks
stephen
you most likely have an air leak some where.

My E46 kicked-up the same code agian and again, First the breather hose on the crank case had a minor split which brought that code up......was fine for a few months after I had replaced it. Light came up again, coud'nt see anything obvious but one day discovered a small oil leak between the Oil filter housing and block........changed the gasket, that stopped the oil leak and I also never had the error code come back since.

These are the probable causes of this error code:

Intake leak, Secondary Air Injection (AIR) system, fuel pressure/pump, injector(s), Evaporative Emissions (EVAP) canister purge valve, Heated Oxygen Sensor (HO2S)



Check for air leaks first..........then I would look at your O2 sensor......these cause problems and do not always kick up an error code.
 

·
Registered
Joined
·
20,393 Posts
You will be better off reading the codes with a BMW specific scanner, P0 codes are not clear enough and don't delve deep enough into the DME(ECU)

You may have some codes present that the Mac scanner won't pick up
 

·
Registered
Joined
·
55 Posts
this looks like it would have been my thread, as my car is experiencing these exact probs too.....and more

to put you guys in picture, i got this P0170 code 18 months ago, so i checked everywhere, and found the crank breather hose was split, so i replaced, but within 12 months, i had water leaks all the time, oil leaks, so all was getting on my nerves.

found the following during 12 months:
cracked thermostat housing...replaced
cracked expansion bottle...replaced
cracked connector as shown in #5 here http://www.realoem.com/bmw/showparts.do?model=AL32&mospid=47631&btnr=11_2082&hg=11&fg=35 ...replaced
pending camshaft position sensor fault...replaced
oil leaking from filter housing to body...new seals and gasket...fixed

still getting P0170 code, so replaced 02 sensor pre-cat still have P0170 fault no matter how many times i clear fault with carsoft 6.5 software

my car is sluggish at take off when cold, and hesitates at lights and standstill to take off, there is a lag of power.
 

·
Registered
Joined
·
1,151 Posts
this looks like it would have been my thread, as my car is experiencing these exact probs too.....and more

to put you guys in picture, i got this P0170 code 18 months ago, so i checked everywhere, and found the crank breather hose was split, so i replaced, but within 12 months, i had water leaks all the time, oil leaks, so all was getting on my nerves.

found the following during 12 months:
cracked thermostat housing...replaced
cracked expansion bottle...replaced
cracked connector as shown in #5 here http://www.realoem.com/bmw/showparts.do?model=AL32&mospid=47631&btnr=11_2082&hg=11&fg=35 ...replaced
pending camshaft position sensor fault...replaced
oil leaking from filter housing to body...new seals and gasket...fixed

still getting P0170 code, so replaced 02 sensor pre-cat still have P0170 fault no matter how many times i clear fault with carsoft 6.5 software

my car is sluggish at take off when cold, and hesitates at lights and standstill to take off, there is a lag of power.


Right dude,

You have 2 possible faults that will kick out a P0170 code (since you've changed all else)


1- change the crank case vent valve- is it leaking/hissing?

2- the MAF is faulty.


seen this many times including on my E46.

If there are no air leaks: It can only be the valve and/or MAF

The valve is around £40 from ECP, maybe cheaper can't remember.

ECP do the Bosch MAF from 120..........they also do a cheaper MAF at around £50 or so, cant remember the brand but If i was gonna keep the car- I would opt for the Bosch.

Go for the cheaper otion of trying the valve first- these fail anyway and do have an effect on emisions- so changing it wont hurt and if it fixes the problem- great!

If you change it and still the light pops up................its the MAF 100%
 

·
Registered
Joined
·
58 Posts
This thread will come in handy no doubt as i have the same fault code... have to say its very disheartening to see all those parts that were changed only to have the fault re-occur! Any updates on this?
 

·
Registered
Joined
·
55 Posts
Right dude,

You have 2 possible faults that will kick out a P0170 code (since you've changed all else)


1- change the crank case vent valve- is it leaking/hissing?

2- the MAF is faulty.


seen this many times including on my E46.

If there are no air leaks: It can only be the valve and/or MAF

The valve is around £40 from ECP, maybe cheaper can't remember.

ECP do the Bosch MAF from 120..........they also do a cheaper MAF at around £50 or so, cant remember the brand but If i was gonna keep the car- I would opt for the Bosch.

Go for the cheaper otion of trying the valve first- these fail anyway and do have an effect on emisions- so changing it wont hurt and if it fixes the problem- great!

If you change it and still the light pops up................its the MAF 100%
oops, that's another i missed off, the crank case valve, i replaced that too last summer as it was hissing as you put it. also, it has had regular services and plugs are changed every 12 months, even though they were not needing replacing, i was just eliminating problems.

but, yesterday, i disconnected battery and i took out the maf sensor and noticed it was carbon'd up, and very dull looking (i forgot to mention, i have replaced the original air box with this one http://www.potn.co.uk/p1544034.htm ) so i sprayed the maf sensor's points with an electrical cleaning spray i obtained from my last place of work, and allowed the vapours to evapourate and left it for 15 mins to reset the ecu and everything.

plugged the maf back in, connected battery again, and started engine, it started to cough, splutter, chug etc....it was like it was running on one cylinder and 1 spark plug LOL, so i thought i had damaged the sensor using the spray, so i turned off engine.

this morning, i took car out for a spin, and it never spluttered once, or hesitated, but engine light is still on.

i will probably read the fault again using carsoft and bmw interface or the scantool software with my cheaper obd tool and interface which is universal but cannot do as much as the bmw one can.
once read, i will erase the faults and turn off the engine light and see when or if it comes back on.

p.s. if anyone in Manchester UK, wants their BMW running on carsoft 6.5 test, give me a shout and i will plug it in for them, no charge, just returning the favour as i have been helped here.
 

·
Registered
Joined
·
58 Posts
Thanks for the update al! Im taking note as you speak!! Keep em coming mate! Good luck. I wish i was closer i'd take you up on that but alas, i might have to invest in some of my own equipment... can't keep paying someone to error check :(
 

·
Registered
Joined
·
55 Posts
only fault picked up on scantool was the P0170 code, so i reset it turned of MIL and drove 15 mile trip to test it.

MIL is still off, so far so good, but best bit is the power is back (i know it's only a 318), yes, 318's are not the fastest, but when you are used to a car that hesitates from standstill, and lags from acceleration, and then now, it's like poop off a shiny shovel again.

next thing i need to fix is my PDC, so today i turned keys to position 2, and engaged reverse gear, put my ears, well one of em anyway, to the rear bumper sensors and 3 are clicking, one isn't, so i will search now for a PDC sensor.

cheers for all help and advice given so far.
 

·
Registered
Joined
·
55 Posts
oh damn, MIL came back on, and still has code P0170 when i read it.

must say though, car seems more responsive since i cleaned the MAF but this damn MIL light is doing my head in.

i must have a leak somewhere still.
 

·
Registered
Joined
·
1,151 Posts
ouch, please NO!!!!!!!!

i am gonna try and look for split pipe in meantime, or if anyone close to Manchester with 318ci wants to swap sensors for a spin around the area to eliminate or prove fault.

cheers

:rofl:rofl:rofl

i know what you mean dude.....................they all say that:rofl
 

·
Registered
Joined
·
58 Posts
Unlucky mate! I was routing for you!...perseverance is key! Its a shame your not closer... hopefully there's another owner near by!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
i still have this problem with my car, and the one thing i did notice was that in the winter when it was very cold the engine warning light went off for a day or so, does this giv any ore clues to the problem with my 318 ci?
regards stephen
 

·
Registered
Joined
·
1,151 Posts
i still have this problem with my car, and the one thing i did notice was that in the winter when it was very cold the engine warning light went off for a day or so, does this giv any ore clues to the problem with my 318 ci?
regards stephen

Are you saying that you got the codes read and got P0170?

If the lights on and you have not got the codes read, then that is what you need to do first.
 

·
Registered
Joined
·
55 Posts
since cleaning my maf sensor my car has got it's power back, and not sluggish any more, but like i said my MIL light is still on showing code P0170, but i did notice yesterday, after i had been driving for over an hour, i parked up on my drive, opened bonnet, and there was a hissing / air leaking sounds like air is being forced out from somewhere under the area marked in red circle.

this is not my engine or picture, it was just one i found on google to show you where i meant.

if it stops raining, i will start taking the covers off the area and narrow down my search.
 

·
Registered
Joined
·
1 Posts
P1070

Hi all,

I've got similar problem with my 318 2000, as the engine management light is on for about a month now, the Oxygen sensor, camshaft sensor and pipes were changed by BMW but still on, last time BMW told me it's the Cat. not working efficiently.

I took to Kwik Fit, as I have guarantee with them, the checked the emission and I told it was ok, but it kept on. Now the reading code is P0170 fuel correction bank1.

I really don't know what to do, as it become too expensive with all these replacements.

Any advice would be most appreciated.
Thanks,
 

·
Registered
Joined
·
55 Posts
Hi all,

I've got similar problem with my 318 2000, as the engine management light is on for about a month now, the Oxygen sensor, camshaft sensor and pipes were changed by BMW but still on, last time BMW told me it's the Cat. not working efficiently.

I took to Kwik Fit, as I have guarantee with them, the checked the emission and I told it was ok, but it kept on. Now the reading code is P0170 fuel correction bank1.

I really don't know what to do, as it become too expensive with all these replacements.

Any advice would be most appreciated.
Thanks,
have you cleaned the MAF sensor m8?

and as i have learned from here, it could be an air leak too.
 
1 - 20 of 33 Posts
Top