BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Hi you may have seen my previous thread discussing aftermarket Mass Air Flow sensors, well I got one from eBay and it has worked wonders, £38 compared to £300 from BMW, it has stopped the intermittent jumping/stalling issues I had
BUT.. after a few days my car has issues when I first start it, Im usually in a rush to work and jump in the car and shoot off but my car wont run right for the first couple of minutes, it has no power and makes a strange knocking noise but after ive drove round the corner and got onto the A roads its fine?
 

·
Registered
Joined
·
528 Posts
Don't use non BMW MAFS. They don't work. I thought mine was shot, tried an Ebay one and fuel consumption went from 32 mpg to 22mpg. Got put the BMW one back on, got the codes read and turned out it was cam sensor and the Maf was fine.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
Ok thanks for your input, my fuel consumption has got alot better since using this aftermarket MAF and general drive is alot better(smoother and more powerfull) but the setting off is an issue, especially when I pull out of my drive and truddle along at 2mph until it kicks in after 1/2mins.

I really cannot afford £300 for one from BMW, is it worth giving my old one a good clean? i did see an online guide somwhere on how to do this, also how much is a camshaft sensor? should i try replacing that with the old MAF back on?

I love my car and it really depresses me when it's not 100% my passenger window has fallen off the rail again! will spend tonight trying to sort that out following the guide somone has posted on here.

Thanks guys
 

·
Registered
Joined
·
7 Posts
You can try cleaning it but be very very careful as the wire is extremely sensitive....and often breaks when a cleaning is attempted
 
1 - 5 of 5 Posts
Top