BMW Forums : BimmerForums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #1
looking for some assistance with the problem I have with my drivers door handle (exterior)

The handle will not open the door from the outside, I've tried the allen bolt inside the door but this has not helped in fact the bolt now appears to have come completely detached

I've taken the handle off the door and the rear of the handle that is inside the door looks intact (its a straight bit with a slight lip on it which appears to catch on a long bar inside the door with a similar lip for the handle to catch on) I've had the handle out from the outside and have tried re fitting it but I can't get it to catch on the bar on the inside, the door opens from the inside and locks etc.

I ordered a new handle which I went and got sprayed however it turns out its the wrong handle as the fitting on the inside has a straight bit with a small hole in it almost as if it might be cable controlled?

I would appreciate any help as I'm tearing my hair out over this,

Cheers

Andy
 

·
Registered
Joined
·
75 Posts
Hi mate, sounds like I have the same problem. After trying myself I booked it into a local garage who found the problem and ordered the correct part (which was tricky to determine) part was £38 and £50 for the labour.
 

·
Registered
Joined
·
206 Posts
Discussion Starter #3
Cheers mate, did they tell you what part it was ? I'm thinking bodyshop now as I have lost the rag and was literally jumping up and down in the driveway like a loon!
 

·
Registered
Joined
·
75 Posts
dont know part number but on the bill it is listed as inside handle cable? Cost £38 from main dealer and £42 for fitting. Hope that helps.
 

·
Registered
Joined
·
155 Posts

·
Registered
Joined
·
206 Posts
Discussion Starter #6
Cheers, i've spoken to a body shop and he has said £90 ball park but as always he wont know til its in bits.

My car has just covered 50k last week so it looks like a common issue, I have started to think the cold has caused it as the passenger side stopped opening this morning but after warmed up it opens fine :confused

Its going in next week will update then with what the issue was and what fixed it.
 
1 - 6 of 6 Posts
Top