BMW Forums : BimmerForums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Hi there again, following on from the possible vacuum hose leak I think I have a more pressing problem. Left the car for 2 days and it has sagged considerably at the back (its a touring 1999 523). Car is right down on its haunches, looks like its trying to sit up and beg!
Can't find a great deal on the internet about this issue but I get a basic impression that there is possibly a leak in an air bag (is that the coil spring effectively?) or the system that inflates them.
Car is up and level when started so the pump must be ok and it looks ok after being left for 12 hours ish so the leak could be slow.
Anyone had this issue? I have got a warranty with the car (only had it a few days) but maybe I should take it to the dealer as it is so recent that I bought it?
Cheers
Alex
 

·
Registered
Joined
·
106 Posts
Hi Alex,
I have a 2000 E39 523i Tourer and had a similar problem to you last year.
Mine wasn't sinking that quickly, but I had the suspension warning light showing up on the dash for ages. I wasn't too worried at the time because if I lifted the tailgate and sat in the back, the compressor started and the car lifted up.
However, eventually it got lower & lower, until it was squatting on the rubber stops.
Turned out to be wires to the level sensors behind the rear wheels (I had a diagnostic check to identify the problem). Fixed the wires, problem solved; no other parts needed.
Hope you'll be as lucky.
Cheers, Tone:thumbsup
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Thanks Tone, sounds like you got off lightly!
finger crossed mine is the same :thumbsup
I haven't had the light on the dash as of yet which makes me suspect it could be something different. Its going to have to be a phone call to the dealer I bought it off and probably some sort of inspection at my cost? :frown

There is a good indy garage near here so I will offer to take it up there and get a diagnostic and see if dealer will pay for the repair. They should do as the car was technically at fault at sale. Anyway I wont bore you with the details.
Will let you know how i go
Cheers
Alex
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Turns out the suspension air bag was faulty. The garage showed me the one that had gone and it was practically brand new! He said it must have been faulty which is strange. Anyway the new one has held the car up for 2 days now so it must have been dodgy. All sorted. I asked if the other one would go as apparently it is the original on drivers side, he said maybe but they don't actually go that often so who knows? Better save that £140 just incase:shifty:
Luckily this work was done on warranty :thumbsup
Cheers for the help
Alex
 
1 - 4 of 4 Posts
Top