BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
The central dash display (which changes with the toggle button) is breaking up intermittantly. Sometimes the data is readable and other times completely unreadable. It seems to improve with the dashboard lights switched on. It also seems like a bad connection somewhere.
In addition the radio randomly goes off. Just switching it on again at the radio knob usually brings it back. Also, the rear window heater when switched on causes so much interference that the radio is inaudible.
All of these symptoms seem like a bad connection somewhere but I am baffled as to where to start. I know that the rear window houses the aerial and it is as if the aerial earth is failing somehow but where is it?.
Would the diagnostic readout reveal anything?
Otherwise this is a fantastic car with only 50K on the clock!!
Any ideas please?
 

·
Registered
Joined
·
540 Posts
Most of the radio stuff is behind the N/S C pillar trim.

The pixel break up is a common fault and BMW's response is a new cluster at loads of money.

There is a guy in Southampton that will repair it for £80, you will need to take the cluster out and send it to him unless you are in the area sometime.

If you take the cluster out the car will be off the road until you get it back.

Also on Ebay there are some diy options for sale.
 

·
Registered
Joined
·
313 Posts
i've been chasing crap audio on my touring for about a year, got nowhere with it as there's apparently nothing wrong with any of my gear - i'd be interested to know if you find a good fix, best of luck!

jim
 
1 - 3 of 3 Posts
Top