BMW Forums : BimmerForums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all,

My first post here. After having owned this beautiful 98 E39 535i it seems I have ran into a little problem with the auto transmission.

Here's what happened today, when it first started was trying to get car home.

4:00pm - Car started to judder when on flat when pulling away in D without using any acceleration. It was smooth prior to this.

4:10pm - Car would lunge on a bank when pulling away from standstill under slight acceleration. At this point driving at normal speed there would be no symptons.

4:20pm - Car judder worse when pulling away from standstill. Sometimes car would rev to around 2K rpm before engaging gear.

4:30pm - Car judder terrible and Trans. Failsafe Prog activated.

After turning off engine and restarting trying to pull away was very juddery. After about 5 to 10 seconds Trans. Failsafe Prog activated again.

Parked car and called RAC. After 2 hours (thankfully I could go home) RAC arrived. We tried the car, started fine. Put it into D. It felt like P was active and transmission locked. Pulled away slowly and clicking noise from transmission and judder. Stopped car and towed home backwards (which is much easier than going forwards without power steering!).

RAC checked under car and could not see signs of leakage. His first opinion was tranny oil or sensor, but after hearing clicking thinks it is something more serious.

Haven't been able to read codes and won't likely be able to until next week. Car safe outside house although it's not going anywhere.

Now, maybe this is my paranoia, but before all this started happening around an hour before I went over a speed bump with wheels on either side. I heard a scrapping noise from underneath as the bump made contact (car has been lowered by one of the previous owners).

Also, about 3 weeks ago I had to replace the expansion tank and bleed the system using info from forums. Later reading today states this could damage the tranny by high revving in P.

I'm calling a garage tomorrow who apparently specialises in BMWs, ex mechanic or something. I'm a computer guy so if it doesn't have a USB connection I really don't know how it works.

Could it be a fast leak in the tranny and all fluid drained out? I didn't notice any clicking when the car first started juddering, this only occurred (at least noticed) at the last start after the car had been sitting for around 2 hours.

All times approximate :rofl

Any help, advice and input most appreciated.

Cheers,

Ian
 

·
Registered
Joined
·
20,393 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Hi Ronnie,

Thanks for the response. I have had the car for just under 2 months. It was serviced around 7K ago by previous owner, but there tranny was not as far as I can see. My thought would be a sudden leakage in fluid from the tranny, but the clicking noise is a mystery too, unless that's what it does when it's really low or something damaged.

I bled the system around 3 weeks ago to replace the expansion tank which failed.

If it is tranny internals, are replacements either reconditioned or repair a viable option in your opinion?
 

·
Registered
Joined
·
20,393 Posts
It may workout cheaper to source a 2nd hand box if it is knackered rather than get yours rebuilt, but lets think positively as we don't know for sure if yours is :hihi

The first port of call should be getting the fault codes read for the Engine and Gearbox :)
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Ronnie,

Yes, I think on Monday I'll chat to the indie and see what he thinks. Might be possible for him to come read the codes outside the house rather than getting the car there. I've read though that most readers will only get emmision faults and not all if any can read the tranny codes. Not sure what kind of kit he would have. Don't want to take it to dealer if I don't have too.

I'll keep the forum posted as I am sure this will be useful for others at some point.
 

·
Registered
Joined
·
20,393 Posts
Ronnie,

Yes, I think on Monday I'll chat to the indie and see what he thinks. Might be possible for him to come read the codes outside the house rather than getting the car there. I've read though that most readers will only get emmision faults and not all if any can read the tranny codes. Not sure what kind of kit he would have. Don't want to take it to dealer if I don't have too.

I'll keep the forum posted as I am sure this will be useful for others at some point.
If he has good enough diagnostic equipment he should be able to read the transmission codes, the cheap code readers will only do engine codes like you mention and they are usually EOBD only which is no good, you need the codes read with a BMW specific scanner, which if he can read the transmission codes then it will be a BMW specific scanner :thumbsup
 

·
Registered
Joined
·
470 Posts
You want to find an auto transmission specialist in your area - ask them how much they would charge for a basic box service....as Ronnie says source yourself a 2nd hand box if you can...if it is ok then get it serviced immediately...a rebuild will be expensive....
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
MTec B,

Thanks. It's at the local specialist now waiting to hear results of diagnostics. They are going to check levels of oil in the box too.

Will let you all know results once I know them. Fortunately, they also have a box in a BMW they are breaking so if I do need one then that's where it could be sourced from. Will have to shop around to see if its a good price, if it does actually need one - which it probably will.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
Hi Folks,

The code for the failure was 056 (the main one) there were two others but I dont have them yet.

Basically they state the gearbox needs replacing / rebuilding.

Anyone any ideas what that code is for?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Actually, it was 059 that was returned by the diagnostics. I can only find one thing on the internet and that relates to the battery being low.

Does anyone have an idea of what this code means?

Car at garage, trying to source a transmission or rebuild.

Cheers,

Ian
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top