BMW Forums : BimmerForums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hi need a helping hand urgently!!!! iv'e got a 525 tds 1998 and warning light has come on dash yellow coil with DDE written underneath have had diagnostics on it and reads code 54(boost pressure sensor) and code 5 (commencment of delivery sensor) have rung bmw dealers but they don't know what im talking about!!!aaarrgh!! im realy confused and don't know what to do.......can any one shed any light on this for me.....:jump
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
its a snap on code reader..iv'e been told code 5 is injector no.4 with a sensor on it and code 54 is boost pressure sensor but that is part of turbo and to replace whole turbo is a bit harsh!!:mad im hoping thst some genius can show me a few shortcuts!!!!!!thanx......
 

·
Bimmerforums Central
Joined
·
8,030 Posts
hi need a helping hand urgently!!!! iv'e got a 525 tds 1998 and warning light has come on dash yellow coil with DDE written underneath have had diagnostics on it and reads code 54(boost pressure sensor) and code 5 (commencment of delivery sensor) have rung bmw dealers but they don't know what im talking about!!!aaarrgh!! im realy confused and don't know what to do.......can any one shed any light on this for me.....:jump
Read the posting and title rules please. At the top of this forum
 

·
Registered
Joined
·
584 Posts
You may find that replacing the injector with the lift sensor first may sort it out,it may flag the boost sensor up par the course because of operating conditions,the lift sensor on injector lets ecu compute the advance/retard timing for injector pump and this failing may cause the ecu to refuse to let engine run with any boost (limp home mode) just a theory though.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
You may find that replacing the injector with the lift sensor first may sort it out,it may flag the boost sensor up par the course because of operating conditions,the lift sensor on injector lets ecu compute the advance/retard timing for injector pump and this failing may cause the ecu to refuse to let engine run with any boost (limp home mode) just a theory though.
i think your quite right doug i have replaced injector and hey dde light has gone off and boost has kicked back in thanx for all your help on this forum guy's.........
 

·
Registered
Joined
·
20,393 Posts
Code 54 is Turbo Boost Pressure Sensor, caused by a break or shorts in the signal, or a faulty TBPS, can also show this code when the signal is not within it's parameters.

Code 5 is Needle Lift Sensor or NLS circuit, caused by a break or short in the sensor,multi plug or sensor circuit. Can cause the car to run in limp home mode.

Was meant to post this up the other night but been a busy boy, sorry for the late response and glad you seem to have fixed it. :)
 
1 - 8 of 8 Posts
Top