BMW Forums : BimmerForums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
I have an e36 318se, I was told that if I bought the OEM alarm box it would just plug into the harness that was already there. After buying the box, I found that for some reason there wasn't a harness fitted (Or at least I couldn't find one) So I then bought a harness. It has all the connectors and an led and sensor fitted. There is also a black plug that plugs somewhere (Where I don't know!) What I really need is some help knowing what to connect the loom to. I have taken some pictures of the loom behind the glovebox and the harness. What I need to know is what goes where as I can quite easily wire it in if I know what to connect to. I cant seem to find a wiring diagram for the e36 OEM alarm anywhere. Just getting the remote locking working would help for now.
Any help would be greatly appreciated.
 

·
Registered
Joined
·
4,071 Posts
3rd picture purple plug is for the central locking. Pin 4 is unlock and 14 is lock (maybe the otherway round so test before soldering.

blue/green and blue/yellow will be your lock unlock wires in pic2 from the alarm unit. Colour will match on your purple plug so should make it easier.

top left connecter in pic 3 should have your main +12v which should be coloured green/red - check with test lamp to make sure its always live even when turning the key to start.

Yours is a different alarm to mine but your job should be relativeley easier to mine as all my wires were black :eek
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Did you have a diagram or a table of what wires did what, and when you say purple plug did you mean wire or the pink connector at the bottom?
Also where do the other wires go like in pic 4, as ive got 3 looms like this coming from the harness.
 

·
Registered
Joined
·
4,071 Posts
the purple plug mate, in the top middle plugged into the ZKE. If you take it out and count along the pins (starting from the right bottom pin) you'll know where to splice into the wires.

I used a multi metre and a testlamp to get my alarm working, and as of yet my glovebox and centre console is still stripped! Still got the full closure to solder in and then job done :D
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
Dont know, I havnt had time to connect any of the wires. I will make a list of what colour wire goes to each pin to the unit. I need to know where some of these tails with funny connectors go. Wheres the best place to take the power from for the unit.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
Right Ive started to patch it in, the thick red/green wire is a perm live. I have joined that to the red/green wire on the unit which is soldered to the red fused wire. I have connected up all the ground wires. is there a black wire needs connecting to the power? Also connected up the blue/green Blue/yellow wires fot the lock/unlock. Noticed that the battery was dead in the key fob. Just gone to get a new one. Do any other wires need patching in to work the remote lock/unlock feature of this? I will work on the alarm next weekend.

Thanks
 

·
Registered
Joined
·
31 Posts
Discussion Starter #10
Connected pins 4 & 17 to the alarm. The car will open from the keyfob but will not close from the fob. Does anyone know what wire operates close on the purple connector behind the glove compartment?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #11
Connected pins 4 & 17 to the alarm. The car will open from the keyfob but will not close from the fob. Does anyone know what wire operates close on the purple connector behind the glove compartment?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #15
Yup I got the siren, its about 2 1/2" with a square connector on the back. I dont suppose you know what wires go where do you? Or why I cant get the remote central locking to lock?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #17
Thanks,
When I arm the alarm (Just to lock the doors, as the alarm part isnt wired in yet) nothing happens on the central locking, but the red flashing led goes out.
When I press the red button, the led goes solid for a few seconds, the doors pen and the lights come on. The led then flashes until i press the grey button.
Bit weird eh?
I posted the pinouts in another thread, i will pm them to you.
Those wiring diagrams would be great, as I want to get is sorted over the weekend.
Thanks
 

·
Registered
Joined
·
2,493 Posts
Got the remote locking working now. I had spliced into the wrong connector. I had used the big purple one ews II or something. I then looked at the little purple one that had the same colour wires in it. There wasn't a wire for pin 17 so I connected one, and presto Red button arms, Grey disarms. I'm going to wire the alarm part in when its a bit warmer.
 
1 - 18 of 18 Posts
Top