BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi,
I have just bought this car with 96k miles on it. shortly after buying the car the "check coolant level" warning came on. When the engine was cool I removed the filler cap to find the indicator sticking up past the top of the filler neck. I put a little bit of coolant in it and the warning went off untill I started the car again next morning. I checked the level again and the idicator was exactly the same. I have been doing this for about a week and everything seemed to be fine. However when driving home today the heater went cold and the temp gauge shot up into the red. I stopped the car and turned off the engine virtualy immedeatly. Steam everywhere. I lifted the bonnet and all around the filler cap and bleed screw were very wet. I waited for it to cool down and filled the coolant level up to the correct level started the car and drove the short distance home. The temp gauge was normal.
Has the radiator, Water pump, Stat or expansion tank gone?
There are so many post on the net all giving conflicting solutions.
Help please
 

·
Premium Member
Joined
·
2,115 Posts
Probably one of those - you could also add lots of nastier things to the list too.

Check the water pump for leaks and play in the pulley (if the water level is going down, where is it going). The stat is a cheap thing to replace so worth a shot. What doesn't get mentioned much but I'm a big fan of is reverse flushing the radiator in case it has got bunged up with crap.

After that you are going to be suspicious of blown head gaskets and cracks in the head/block. A hydrocarbon sniff test thingy and/or a pressure test at your local garage might be worth a try.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Overheating

Thanks.
I have just changed the Expansion Tank, Filler Cap and Bleed Screw and tried to bleed the system. Go nothing coming out of the bleed screw when the system was up to normal temperature. Bled the heater too, but thats still cold. The Sticker on the side of the radiator says it was manufactured in 2002 so it must have been changed since then.
:frown
 
1 - 3 of 3 Posts
Top