BMW Forums : BimmerForums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi All,
Just recently I have found that my 328i began to feel unstable when accelerating. It is as though the back end was wanting to slide when power was applied. Also going over bumps, it was as though the car wasn't under control. Quite scary when getting up to speed joining the M6 with 220 miles to get home! (50MPH in the inside lane and 5 hours later I got it home)
The only way I can properly explain it is that it's as though I was on a skid pan or I had diesel on the tyres (needless to say, I didnt).
Has anyone else had this kind of experience or have any idea what it could be.
I had new rear brake drums (handbrake failed MOT) and discs fitted in December 2008, if these were fitted badly, could this be the reason?
Thanks :)
 

·
Registered
Joined
·
2,255 Posts
Thanks Mark,
Do you have any idea how much can I expect to fork out if it is the Trailing arm bushes?
Tyres were OK for MOT but I'll replace them and see if it sorts the problem.
Cheers :)
My rear control arm busghes and trailing arm bushes were well shot! Yet fully passable for MOT :confused they moved around like prisoners out in a courtyard at playtime. The back end was all over the place, making it hard to keep the car in a staright line etc. In the wet hitting drain covers caused minor irritating twitches etc.

Bushes are cheap enough, take a look at www.eurocarparts.com, select your vehicle, find the parts you want and it will show you the options & price!

It willl most definately be worn suspension related.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Thanks all for your replies lads. Problem diagnosed absolutely spot on, local garage (Ex BMW techician) has sorted it and replaced the bushes. All tickety boo now £80 all in, will have 4 wheel alignment when I get tyres with next months pay !

Thanks again :)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top