BMW Forums : BimmerForums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
My windscreen washers are useless on my compact, drivers side does spray but is gutless and the passenger side squirts barely more than a drizzle!!

Does this sound like the washer pump? It has been like it since ive owned the car but MOT is due end of the month and worried it may not pass...
 

·
Registered
Joined
·
49 Posts
Hi if look where the washer bottle is ,on the side is the pump ,pull that out of the bottle ,there should be a filter in it that which is probally blocked with old sceen wash residue,also check the two non return valves are working ok they also block and water comes out the hole on the side ,6.00 from BMW .To get to these you need to lift up bonnet and remove lower half of heat shield ,The black thing attached to bonnet Good luck
 

·
Registered
Joined
·
10 Posts
i had this but mine was a leaky pipe as it conected to the back of the jet trimed the naf bit stuck it back on works fine now. easy check for this just see if heat shields damp after spraying .
 

·
Registered
Joined
·
1,240 Posts
mine was the filter. same effect. cleaned up and the jets really are jets now.
Remove pump and tease the filter out. clean filter and shove it back firmly. Plugs in like a rubber bung.

quick easy job. I had my water bottle out to clean it and even that only took around 20 mins. doing the filter is a 2 minute job.
 
  • Like
Reactions: seanb_007

·
Registered
Joined
·
49 Posts
thanks will take a look this weekend... are both the non return valves the same?
yes both valves the same ,do the filter first ,if it works job done ,but you could check valves as the tend to block or partly block leaving waer dripping on heat shield making a soggy foam mess..
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
Had a good look today, someones definetely been in there before the filter was missing from the washer pump/bottle ... the inline valves were also not there... both the washer jets had the right angles snapped off the bottom of them and the pipe had been zip tied to the broken jets. will go scrappy and try and find some good ones ( they were heated too )...
cheers for all your help
 

·
Registered
Joined
·
163 Posts
I've just finished this job today. I had the passenger jet non operational and the drivers side pretty lame.
On inspection the two jets were clogged.
I've got rid of the one-way valves on both sides as when the jets are clogged screen wash p****s out the small holes, runs down the inside of the bonnet liner and rusts the bonnet catches and eventually delaminates the bonnet metal.
To check this simply feel the bonnet liner around the catches and see if damp.
 
1 - 8 of 8 Posts
Top