BMW Forums : BimmerForums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone, new here and need a little help please.
my E31 key fob has stopped working and doesn’t lock or unlock.Unlock with the key, all locks work, open the door and the alarm sounds and hazards flash. Enter the car and shut the door and windows rise but alarm and hazards still going. Put key in ignition and turn and no response but alarm and hazards still going. After about30 seconds the alarm stops but hazards still going but stop after a couple of minutes. Exit car which of course sets off the alarm and hazards and notice the sunroof is up on tilt. New battery in keyfob makes no difference. Headlights don’t pop up.
can anyone help here please?
Thanks
AlanB850
 

·
Super Moderator
Joined
·
3,469 Posts

·
Registered
Joined
·
6 Posts
Hi everyone, new here and need a little help please.
my E31 key fob has stopped working and doesn’t lock or unlock.Unlock with the key, all locks work, open the door and the alarm sounds and hazards flash. Enter the car and shut the door and windows rise but alarm and hazards still going. Put key in ignition and turn and no response but alarm and hazards still going. After about30 seconds the alarm stops but hazards still going but stop after a couple of minutes. Exit car which of course sets off the alarm and hazards and notice the sunroof is up on tilt. New battery in keyfob makes no difference. Headlights don’t pop up.
can anyone help here please?
Thanks
AlanB850
[/QUOTE]
Hi Alan, I have a similar problem with my 840ci and just wondered if you resolved the issue? Did reprogramming the key resolve the issue? Cheer Phil
 

·
Registered
Joined
·
6 Posts
Hi Timm, thanks for your post! I have watched your video which was really helpful but unfortunately reprogramming didn’t work. I did have an intermittent ignition switch which might have been the problem so will try again. Is there anything else that you would suggest. I also have a 70ah and 72ah battery connected which I think in your battery video you suggest is a no no! Could that be my issue?
 

·
Registered
Joined
·
6 Posts
I’ll try programming it again and if that doesn’t work I’ll go for the 2nd hand key! Thanks for your advice.
Hi Timm,

just thought I’d update you on my progress. So I tried reprogramming the key again but that didn’t work. Perhaps it has too many keys programmed? Anyway I decide to deactivate the alarm electronically following this procedure in the manual. It seems to have worked so I can now use the car albeit without the alarm going off but at least I can’t crack on with all the other jobs that need doing!
 

Attachments

·
Registered
Joined
·
6 Posts
Hi Timm,

just thought I’d update you on my progress. So I tried reprogramming the key again but that didn’t work. Perhaps it has too many keys programmed? Anyway I decide to deactivate the alarm electronically following this procedure in the manual. It seems to have worked so I can now use the car albeit without the alarm going off but at least I can’t crack on with all the other jobs that need doing!
Not sure how to reactivate the alarm so if anyone knows please share!
 
1 - 13 of 13 Posts
Top