BMW Forums : BimmerForums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
hi all,

the heater is really a bit strange on my 323 auto, it has the dual zone climate control.

it gos like this...

when i set off in the morning i set the climate an 22 degrees. (with the aircon off) the car heats up nicely just as you would expect. but then in about half an hr, the heat start to go cold. so i turn it up to 30 to get it back to warm. it then heats up again. obviously this is way out because there is no way its actually 30 degrees.

when the car is left to cool down the process will start again.

i have removed the pollen filter from car. the same thing happens regardless of the aircon being off or on.

anyone have any ideas? thermostat maybe?
 

·
Registered
Joined
·
20,393 Posts
I would first ensure the cooling system is bled correctly

1.Jack the front of the vehicle up onto stands as high as possible,
2.Turn the ignition on,engine off,heater on fan setting 1 and temperature fully hot,
3.Remove the rad cap/expansion cap,remove the bleed screw from the rad and IF you have them the bleed screw(s) from the thermostat housing/top hose, return pipe or EGR thermostat.
4.Fill the radiator up and keep pouring till there are no more air bubbles coming out from the bleeds, when good then install bleeds and tighten down(don't snap them),ensure the rubber O-rings/seals are still on the screws/on the bleed holes.
5.Suck some water out so it's not full to the brim, replace the cap and then start the car. Run her up and check for heat from the vents when warm and check if over heating still persists.
6.If good then check the water level again in the morning when cool.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top