BMW Forums : BimmerForums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Hi guys, I'm new here, having just bought my first BMW last week, and having a few teething troubles that I hope someone can help me out with...

On first starting the car and driving away, the abs cuts in every time I brake (Pedal vibration) until it just turns itself off with the abs and dsc telltale lights glowing amber on the dashboard. From a bit of research, I am led to believe that this is caused by either of the front wheel speed sensors, as I am having no problems with odometer or speedo...

Question is, how easy a job is this to replace sensors myself, and is it actually the sensors at fault, as no other articles I have read on this mention that the abs cuts in every time until it turns off completely?



Secondly, and quite minor really, The electric rear sunblind does not work, I have checked fuses and all are fine, any ideas whatto check next/likely cause of this?

Thirdly (again minor), The clock display does not work on the radio display, it is just blank, again, all fuses are ok.



Thanks for reading:cool
 

·
Bimmerforums Central
Joined
·
8,030 Posts
Hi, I just tweaked your title a bit as per the posting guidelines ;)


First things first, have you had the fault codes read from the car? because that is the first thing you need to do...

It could be the ABS ECu at fault, try pulling the ABS fuse and see if that stops the juddering and it will narrow the problem down.

Electric sunblind - could well be the wiring that runs under the boot hatch...this is a known problem on E36s but I have not heard of it as yet on E39s..

clock - I will check on this.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #3 ·
Hi, I just tweaked your title a bit as per the posting guidelines ;)
Cheers mate:thumbsup

First things first, have you had the fault codes read from the car? because that is the first thing you need to do...
Not yet mate, I'm loathe to spend the cash to be honest, having just spent out on buying the car...

It could be the ABS ECu at fault, try pulling the ABS fuse and see if that stops the juddering and it will narrow the problem down.

Will have a go later when the wife gets home to watch the little'un


Electric sunblind - could well be the wiring that runs under the boot hatch...this is a known problem on E36s but I have not heard of it as yet on E39s..
Will also check this later, where does the wiring run? It's a saloon, so I wouldn't have thought that the wiring would run through the boot lid, although I could be wrong??
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #5 ·
It could be the ABS ECu at fault, try pulling the ABS fuse and see if that stops the juddering and it will narrow the problem down.
Just pulled the fuses (there are 2 according to the fuse diagram)
with number 31 out the car doesn't even start
Number 30 out it solves the juddering, as the abs and dsc lights are both on meaning they are not active...is this indicative of a failed sensor??

Electric sunblind - could well be the wiring that runs under the boot hatch...this is a known problem on E36s but I have not heard of it as yet on E39s..
I was unable to find the wiring for this, which panels will I need to remove to find it?:confused
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top