BMW Forums : BimmerForums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
Evening to All,

i've owned the above car for about 3yrs and since the day i collected it, its had a noisey rear suspension, when i go over speed humpS or anything similar. it was lowered by a previous owner and since then i've added my sub-box which is quite heavy. i've recently replaced the rear wishbone front bushes, the shocks and top mount bushes but the noise is still there - not as bad coz the shocks are from an M3 so it doesnt move about quite so much

i was thinking that possibly the subframe bushes are at fault. the car recently passed its MOT and has always done so even though on two occasions the tester mentioned the noise/creaking

any ideas as to what's causing this noises?

one other thing, from time to time since i changed the discs/pads all round, my ABS light comes on. usually it stays there till i park and turn everything off and on one occasion when braking, the car felt like its about to go into a skid but the ABS is trying to keep it from skidding, even though im only slowing/stopping from a low speed. how much trouble is it to replace the ABS sensors and i assume there is one sensor per each wheel??

thanks for your help folks


cheers
bf
 

·
Registered
Joined
·
528 Posts
Yup, there is one per wheel. In theory they are very easy to replace. Just unplug it and unbolt it from the hub. In practice it has been there for 15 years and has rusted in so it'll need drilling out. But I'd never done one before and I managed it in 2 hours, but I was being pretty timid with it at first.
 
1 - 2 of 2 Posts
Top